Particle System - Hair - self force field effect stops on frame 100
Closed, ResolvedPublic

Description

Win10, 64bit, Nvidia GeForce 840M, all up to date

2.78.a official

Effect of force field on hair-system stops at frame 100

Open attached blend file and playback animation (Strg-A).
Till frame 100 the hairs are driven apart by the force-field, then the effect stops and the hairs falls down.

Force field on external object (empty in scene) works over all frames.
But second bug(?):
if before mentioned bug has been tried out, the force field on the empty is not taken into account, even if cache is cleared, rebaked... (red line in time line stays).
Only changing particle number i.e. from 100 to 101 and back to 100 clears the "cache"-red-line and then the empty-force-field pushes the hairs.

Details

Type
Bug

The force field panel was designed with emitter particles in mind.
To make this kind of effects. https://vimeo.com/19187192
The idea is that some particles of particle system will be force fields moving as particles to influence the other particles of the system.

So, nobody really tested the use of hair particles as force field at its creation.
Emitter particles and Hair particles are sharing same UI.
And presence of this panel for Hair particles is probably an oversight.

Emitter particles have a lifetime. On the contrary, Hair Particles does not born or die.
It is probably the reason of the problem.

Hair particles have a static root. You can use empties as force fields at same location to obtain same effect

In the future, emitter particles and hair particles will be separated. But currently, there is no developer working on particles.
All projects about them have been postponed to the end of 2.8 projects.

Thanks for your reply and your suggestion, which works fine.

Joey Ferwerda (TheOnlyJoey) closed this task as "Resolved".Jan 19 2017, 5:29 PM
Joey Ferwerda (TheOnlyJoey) claimed this task.