Particle system based on "face count emitting" produces error
Open, ConfirmedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: 2.78a

Short description of error
Emitting particles in according with face count is not quite right
One Cube is missing


Details

Type
Bug
Serge Lyatin (SergeL) changed the title from "Particle system based on face count emitting produces error" to "Particle system based on "face count emitting" produces error".Jan 27 2017, 11:38 AM
Joey Ferwerda (TheOnlyJoey) triaged this task as "Confirmed" priority.Jan 27 2017, 12:10 PM

Can confirm.
This did work on Blender 2.77, issue seems to be a simple off by one.
Same occurs for Volume rendering.

When opening in 2.77 and switching to Volume and back to Face fixes it.

I encountered this issue a long time ago. It also happens when emitting from vertices. It is odd because it only happens with certain vert/face counts.

IIRC when I looked into it, I found that the particles weren't actually missing, but rather some particles are being generated at the same location as others.

So @Joey Ferwerda (TheOnlyJoey), sadly I'm afraid it is not as simple as an off by one thing :\

There should be closed duplicate report about that.

With all hesitation about abandon, re-factoring, removal, re-integration of particles; I am not surprised that such bug comes back in 2.78a.

Problem is not random. It is relative to indices.
On face with index = 0, there are 2 particles emitted instead of one.

I was about to report this too. With particles set to Hair type or Emitter type, and 1 particle per face, on an arrayed plane, matching the particle count to the exact number of faces produces a similar behavior.

There is apparently always one particle always missing, but upon closer inspection the "original face" always has two particles overlapping, leaving one face empty.
One always has to artificially increase the count by one, but that doesn't really fix the double particle in face zero.

Probably related to T47983, but with the upcoming 2.8 refactor it might not be worth it to waste time fixing this now.