fluid cache folder bug (cyrillic in path)
Open, NormalPublic

Description

System Information
Windows 7 64 bit

Blender Version
2.78b 64 bit 3с04373

Short description of error
The liquid is not created if the path to the cache is Russian characters.

Exact steps for others to reproduce the error
blend file:
https://drive.google.com/open?id=0B-iM4MC7-TrhX1g4OC10blVFMWs

Details

Type
Bug

I can test this for you but your test blend file seems not to work at all.
Can you retry setting up the case with a render-able result and re-upload the blendfile?

Also please attach it using the bugtracker, don't use external links

Bastien Montagne (mont29) triaged this task as Incomplete priority.Feb 9 2017, 5:14 PM

If you set the path to the cache as in the picture, the fluid simulation is not going to happen:

I get that, but even when using a 'regular latin' path you can not render with your blend file example, the blend file does not render at all (missing camera,light etc) so please update your blend file to a render-able result and i will test your case.

I think Pavel experiences a problem with baking fluid simulation in case when path to simulation cache contains Cyrillic (any localized?) symbols when running on Windows 7. That is 'good' is when cache files are created by Blender after hitting 'Bake' where was specified by path given and 'bad' when there is no cache files in the folder after hitting 'Bake'.

I have Linux and can't reproduce the issue. Cyrillic letters are working fine for me. Also file provided by Pavel gives no simulation to me, only simulation cache files are created after hitting 'Bake'. File provided by Characterhero have simulation visible in Blender's viewport after baking without rendering it. But again - having Linux I can't reproduce the issue.

Bastien Montagne (mont29) raised the priority of this task from Incomplete to Normal.

Yes, we need some dev on windows to investigate this… Linux handles utf-8 paths since ages, not windows. :(