Page MenuHome

Blender crashed and now it's extremely slow
Closed, ArchivedPublic

Description

System Information
Windows 10, Nvidia GTX960M

Blender Version
2.77 and 2.78

Short description of error
While working, Blender crashed. When I reopened the software it had become very slow to the point where it is unusable. Starts up at normal speed but everything within the software (rotating the viewport, navigating menus etc) lags. I have tried the following:

-Restarted blender and the computer
-Reinstalled blender with 2.77 and 2.78b
-Deleted the Blender Foundation folder before installing blender again
-Checked that I'm indeed using the graphics card
-Tried setting cycles compute device to CUDA
-changed image draw method to GLSL (was by default set to 2d texture)
-loaded factory settings

Exact steps for others to reproduce the error
I THINK I pressed tab before it crashed, I might also have hit one of the surrounding keys and held for too long perhaps?

Details

Type
Bug

Event Timeline

Vuk Gardašević (lijenstina) closed this task as Archived.

There are several reports about Blender running slow on specific Nvidia cards / drivers combos - usually laptop variants.

This task is the same/ similar as T49758, T50154, T50142, T50175, T50191

Since it is a GPU driver problem, I'm afraid that there is not much we can do.

Try possible workarounds from this post, if that doesn't work try to install an older/newer/different Nvidia driver that did (the reason I'm saying that is that it's not always sure that the new driver will work better or correctly - try to find a driver that works).

Sorry for the inconvenience, but as You probably already noticed GPU drivers from all vendors (Amd, Intel, Nvidia) are awful each in it's own beautiful way. :|

Closing as archived.

I'm not sure I was clear about this - but Blender was running perfectly fine up until the crash, old drivers and new, so it's not a problem with my graphics card. Other software is also running just as they have, so i'm convinced the problem lies within blender.

I'll try the workarounds.

Thanks.

Let us know if you have further information, so we can reopen the task if needed.

please can you show your graphic information and video memory ?

Alright guys, I managed to fix it believe it or not. So I noticed the start up message said:
Al lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead. I googled that and found a solution with placing opengl32.dll in the same location as the blender.exe - that did the trick.

Thanks anyway :)

In T50643#417053, @Lars Erik Helgemo (helgemonster) wrote:I googled that and found a solution with placing opengl32.dll in the same location as the blender.exe - that did the trick.

Well, this is not a solution. The opengl32.dll is made for testing purposes, it runs GPU computations on the CPU, bypassing the driver. You'll notice Blender runs extremely slow with it.
However, this does tell us that this is indeed a graphics driver issue. Nothing that can be fixed on Blender's side.

Alright guys, I managed to fix it believe it or not. So I noticed the start up message said:
Al lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead.

This message is completely harmless and is nothing but a notification about Blender's audio settings. It has nothing to do with the issues you're experiencing.

After dabbling a little bit in blender afterwards, I figured it wasn't exactly a fix. It's still slow, but it's way faster than what it used to be. Considering the fact, I'm not sure why it doesn't work properly, and why it is only Blender since all my other software seems to be running perfectly fine (zbrush, photoshop etc). And why it happened straight after the crash.

I managed to fix this, at least for me. I had the same problem as the OP, and the same system details: Windows 10 and Nvidia GTX960M.

Device Manager said all my drivers were up to date, but upon further investigation this turned out to not be the case. I opened "GeForce Experience", clicked "DRIVERS" (on the tab in the top-left), and clicked "Check for updates" (in the top-right). Apparently there was a driver update Device Manager didn't pick up.

It's called "GeForce Game Ready Driver". The version number is 378.66. After installing that, Blender is now working perfectly again.

I managed to fix this, at least for me. I had the same problem as the OP, and the same system details: Windows 10 and Nvidia GTX960M.
Device Manager said all my drivers were up to date, but upon further investigation this turned out to not be the case. I opened "GeForce Experience", clicked "DRIVERS" (on the tab in the top-left), and clicked "Check for updates" (in the top-right). Apparently there was a driver update Device Manager didn't pick up.
It's called "GeForce Game Ready Driver". The version number is 378.66. After installing that, Blender is now working perfectly again.

Brilliant! That seemed to fix it - additionally, another workaround was to use the integrated graphics card. I believe it could pose a problem to heavier scenes, but for my work it worked just fine. But now that this is working, I couldn't be happier. Thanks to everyone who gave their thoughts on the issue!

I'm still curious as to why this happened in the first place, since it did work just fine before, but all is well that ends well I suppose.