[BGE] Libload status progress is not progressive
Closed, ArchivedPublic

Description

System Information
Windows 10
GTX

Blender Version
2.78b

Short description of error

In order to make a progress bar, the value needs to change over time according to loaded data.

LibLoad status progress only outputs 0.0 and then 1.0 when the lib is loaded.

There is no progress at all such as : 0.0 0.1 0.2 0.3 0.4 0.5 0.6 0.7 0.8 0.9 1.0.

status = bge.logic.LibLoad('//xxx.blend', 'Scene', async=True, load_actions=True, load_scripts=True)

storing the status in some global object, then accessing it from another logic brick while the game is running.

print(status.progress)

Details

Type
Bug
Sergey Sharybin (sergey) closed this task as Archived.Jun 9 2017, 11:47 AM
Sergey Sharybin (sergey) claimed this task.

Progress depends on the number of scenes to be read, and totally ignores progress based on objects in the scene. So if you've got single scene, you'll indeed have progress of 0 changing with progress of 1.

This isn't really great, but this is how things works by design currently, hence not considered a bug. Thanks for the report anyway.

P.S. Game engine would need to have some re-design for 2.8 project..