Volume rendering with GPU bug
Closed, ArchivedPublic

Description

System Information
Windows 10, Intel Core i7 5820K, 32GB, NVIDIA GeForce GTX 1070

Blender Version
Broken: 2017-02-25 02:12 Hash: 8c5826f
Worked: (optional)

Short description of error
Some CUDA errors like: cuCtxCreate: Launch failed
or corrupted image when switching volume on.

Exact steps for others to reproduce the error
Sorry, I am a beginner with blender
If I choose Volume (Glass BSFD) in world, CPU rendering is normal,
but GPU Compute fails with error or disrupted image.

Details

Type
Bug
Sergey Sharybin (sergey) lowered the priority of this task from Normal to Incomplete.Mar 3 2017, 11:08 AM

I can't see any issues with the attached file on GTX1080.

What are the exact steps reproducing the bug with the file attached?

Martin (MEDT) added a comment.EditedMar 3 2017, 6:19 PM

Open Blender
Select World
Volume
Select Glass Bsdf
Render with Cycles on GPU

No Error if using CPU

Same with bmw27_gpu

Bastien Montagne (mont29) raised the priority of this task from Incomplete to Normal.Mar 14 2017, 3:36 PM
Sergey Sharybin (sergey) closed this task as Archived.Mar 22 2017, 2:29 PM

Had a look here. So far managed to reproduce on Windows, didn't see this error on Linux. Most likely it's because of different timeout policies on different platforms (those timeouts are dictated by driver and OS and out of our control). The issue is very similar to the one described in out manual [1]. It is not solvable in general case for as long as the card is not dedicated for compute (aka, has monitor attached to it).

Some ongoing development which could improve situation here:

  • Using non-volume and non-emission BSDF for volume output is quite meningless and not supported by the renderer. It is more like a corner case which is allowed by the interface. Such issue is i'm trying to address in D2569.
  • Using automatic workload size for GPU. Currently the workload on GPU equals to tile size (which is 1024 for viewport render) which could be a bit too much. Some adaptive scaling of workload could help here.

For now i'd just suggest avoid having such a setups which confuses render engine or use CPU for a complex scenes or use a dedicated card for compute. There is really not much we can do about such issues.

Thanks for the report anyway.

[1] https://docs.blender.org/manual/en/dev/render/cycles/gpu_rendering.html#cuda-error-unknown-error-in-cuctxsynchronize