Page MenuHome

Bevelling an edge loop gives bad geometry
Closed, ResolvedPublic

Description

System Information
Suse Leap 42.1
NVidia GTX 560ti (official drivers)

Blender Version
Broken: all tested versions

Short description of error
The bevel seems inconsistent; when working with single or multiple edges, new geometry doesn't move past adjacent existing geometry (as expected). But when bevelling a complete edge loop, the new geometry isn't constrained in the same way and overshoots.

I can't think of a situation where this would be desirable.

Demo video:
alternative link: https://youtu.be/bBjjFsImcOc?t=14

Exact steps for others to reproduce the error

  • add a torus and select a complete edge loop
  • bevel
  • geometry overshoots

Details

Type
Bug

Event Timeline

Paul R (intracube) removed Howard Trickey (howardt) as the assignee of this task.

Looks like there's no single video format that's compatible with modern browsers...

Hopefully the Youtube link works.

@Aaron Carlisle (Blendify) right click save as, seems to do the job for me

Sorry, I haven't had a chance to look into this yet. The code that prevents overlap is (the 'clamp overlap' option) is only approximately right, since getting it really right is quite hard. But I agree it seems to be failing completely in the case of selecting a whole loop, and hopefully it will be easy to figure out why and correct it.

There seems to be two independent clamping events/rules. The 'clamp overlap' option only affects whether new bevel geometry overlaps other new bevel geometry. But even with that disabled, the bevel doesn't normally cross over pre-existing geometry (which seems sensible) - unless you're bevelling a complete edge loop.

example:


^ two adjacent edges bevelled with clamp overlap disabled, the new geometry (purple) can cross over each other, but is still constrained by the existing edges (green). The other side of the bevel can still continue outwards until it too hits existing geometry (yellow).

A side-issue; with clamp overlap enabled, the bevel sometimes stops short:

In that setup, It should reach the midpoint.

Bastien Montagne (mont29) triaged this task as Normal priority.Mar 3 2017, 9:20 AM

The fix just committed only fixes this bug if the 'Clamp overlap' option is enabled. The fact that sometimes the existing code stops the edge slides when it hits another vertex was not something that was intended to find and fix all geometry collisions. Even 'Clamp overlap' doesn't do that, though it tries harder.

Hi,

I can confirm this fixes the clamp function in all bevel modes except for 'percent' - in that case the bevel still sometimes stops short.

Bevelling two adjacent edge loops on a default torus works, but if the loops are shifted apart beforehand, the newly created geometry doesn't meet up with itself.

Howard Trickey (howardt) closed this task as Resolved.Mar 21 2019, 12:03 PM

Clearing out old bugs. Clamping is currently working as intended, even if not ideal. The long term fix is to actually have the geometry merge and/or otherwise do intelligent things when collision happens, and then remove 'Clamp' completely. I hope to get to that as my next big bevel improvement project, though it is some time off.