[Check support for Windows Ink new tablet API] Windows ink gives laggy viewport navigation in sculpt/paint modes when using emulate 3 button mouse.
Open, NormalPublic

Description

System Information
Operating system and graphics card
Windows 10, Nvidia GTX 1060

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
2.78c
Worked: (optional)

Short description of error
Lag in view nav for sculpt/paint modes when windows ink is enabled and using emulate 3 button mouse.

Exact steps for others to reproduce the error
I have an xp pen tablet. When I set the driver to use windows ink I get some weirdness and inconsistencies in view nav in different modes in blender:

When using a tablet i tend to use "alt" based navigation rather than middle mouse button so have set "emulate 3 button mouse" in preferences.

All is fine when in object or edit mode but in sculpt mode, weight paint or vertex paint there is a long delay (variable and up to about a second) before the view obeys "alt" navigation input. seems worse when using alt shift or alt ctrl for panning and zooming.

It's instantaneous when using middle mouse button based navigation. (with and without ctrl or shift)

If i turn windows ink off in the tablet driver everything is consistent and good across all modes.

I guess this is the very definition of corner case. Unfortunately photoshop only respects tablet pressure when windows ink is on and it's a pain to constantly edit the driver settings!
Turning off windows ink fixes the issue.

Details

Type
To Do
Bastien Montagne (mont29) triaged this task as Normal priority.

Not sure we can do much here… we need a windows dev to investigate anyway. But issue is probably a mix of driver and windows handling of tablets that conflicts with older API… Supporting ink in Blender is more of a TODO than anything else.

Bastien Montagne (mont29) renamed this task from Windows ink gives laggy viewport navigation in sculpt/paint modes when using emulate 3 button mouse. to [Check support for Windows Ink new tablet API] Windows ink gives laggy viewport navigation in sculpt/paint modes when using emulate 3 button mouse..Jul 4 2017, 5:47 PM
Bastien Montagne (mont29) changed Type from Bug to To Do.

Hello, I am going to try to fix this.

Yea I couldn't reproduce this on my tablet, but its a Wacom...