Problem with weight paint and particle system
Closed, InvalidPublic

Description

System Information
Windows 10 and Windows 8.1
Simple graphic card and Nvidia graphic card

Blender Version
2.78b

Short description of error
When I reproduce grass in a large surface, and distribute it by weight paint, the distribution of grass seems don't follow the area I define with paint, and it seems to be more diffuse in inclinate surfaces instead of plane surfaces...

Exact steps for others to reproduce the error
I attach a Grass.blend example (zip file) with a big surface and simple particle system settings.

Details

Type
Bug

I have looked into provided file and found out that plane has scale values of 25-25-1, when I apply the scale and update hair distribution by entering and exiting Weight Paint mode, it starts to look accurate to the weights. I have also noticed that certain areas visually look denser due to hair’s shape (Spiral) and direction, when I switch hair Display option from Rendered to Path, distribution also looks accurate. My guess is that uneven Scale values are the problem here.

Luca Rood (LucaRood) closed this task as "Invalid".Mar 26 2017, 2:54 PM
Luca Rood (LucaRood) claimed this task.

Like @Alex (SpectreFirst) said, the issue is the scale. Particle distribution is calculated in local coordinates, thus distribution will be off when the object is scaled unevenly in global space. Applying the scale fixes the issue.
No bug here, closing.