Wrong view rendering mode, on orthographic view , black rendering of some glossy surface.
Closed, ResolvedPublic

Description

System Information
Lubuntu 16.04 Intel® HD Graphics 5500

Blender Version
Broken: (2.78c e92f2352830, and 2.78.4 e8021f5e3b)

Short description of error

Exact steps for others to reproduce the error
Hi, I found this bug some time ago, but I was hoping someone would report, it did not happen and so it's up to me. This is an error rendering of some shaders from above, in the orthographic view. I attached is the file with the error clearly visible.
Open the file and on top view port, change display shading mode to rendering mode.

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as Confirmed priority.

Actually, am getting a crash here when trying to render from top view with debug build:

blender: /home/i74700deb64/blender/__work__/src/intern/cycles/kernel/./closure/../closure/bsdf_microfacet_multi.h:90: ccl::float3 ccl::mf_sample_vndf(ccl::float3, ccl::float2, ccl::float2): Assertion `isfinite(slope_x)' failed.

@Sergey Sharybin (sergey) assigning to you by default since it’s Cycles issue… ;)

Sergey Sharybin (sergey) closed this task as Resolved.Mar 20 2017, 3:03 PM

Fixed this in rB18bf900. Thanks for the report!