UV Map random swap - with multiple materials and UV Maps
Closed, ResolvedPublic

Description

System Information
Windows 7 64-bit
GeForce GTX 680

Blender Version
Broken: 2.78c official release
Worked: 2.78a official release

Short description of error
When an object has more than 1 material and more than 1 UV Map (each material using a different UV Map in the material nodes), occasionally a material will use the incorrect UV Map during animation. On average, it happens around 4-8 times per 100 frames.

Very rarely it might crash.

I could not reproduce this with only 1 material and multiple UV Maps.

Exact steps for others to reproduce the error
The attached file has 1 object with 2 materials, each using a different UV Map.

  1. open file and Render Animation
  2. check animation result

If same problem occurs, a dot will move occasionally (uses different UV map) on a few frames.

Details

Type
Bug

In my testing, the problem doesn't occur in the following situations:

  1. 'Open Shading Language' enabled

Which is not very helpful when depending on GPU rendering

  1. 'Persistent Images' enabled

Not sure yet how this would affect more complex animation

I'm testing the latest build, and I cannot reproduce the issue any more.

Tested on
blender-2.78.0-git.bca6978-windows64

So whatever happened, it seems fixed

Dalai Felinto (dfelinto) closed this task as "Resolved".May 22 2017, 12:39 PM
Dalai Felinto (dfelinto) claimed this task.

Closing then. Thanks for the report, and hi @Sacha Goedegebure (sago) :)

Okay, let's hope it stays resolved.

And good luck with bug solving!