UV editor, UV unwrap operation misbehaving between different Render Modes
Closed, ArchivedPublic

Description

System Information
Windows 10, 16MB ram, COG8580 Asus, Nvidia 970GTX Strix

Blender Version
2.66a - 2.78b

Short description of error
UV unwrap operation "Correct Aspect" stops functioning as intended in "Cycle Render" Mode.

Exact steps for others to reproduce the error
(Do these in Default "Blender Render" Mode or "Blender Game" Mode)

  1. Unwrap a simple box.
  2. Create a none 2 by 2 texture map file.
  3. The uv stretches in the uv editor accordingly with the newly created rectangular uvmap.
  4. Now reapply Unwrap with "Correct Aspect" turned on, uv is corrected and behave as expected.
  1. Do those same 1-4 steps in "Cycle render" mode.
  2. You will discover that uv unwrap does not react with "correct aspect" turn on or off.
  3. It's as if "correct aspect" stops functioning in "Cycle render" mode.

(During the probe into the bug, I also found an interesting behavior. In both "Render Game"
and "Blender render" Mode. If you create 2 separate uv editor window on screen, changing
one texture map display on screen automatically changes the other. However, in blender
cycle mode, you can have 2 different texture map showing on 2 different uv map editor
window. Makes me wonder if it's this behavior that causes "correct aspect" to stop working)

Details

Type
Bug
hawkenfox (hawkenfox) edited the task description. (Show Details)

For context this comes as a from followup for a Blender Stack Exchange question.

Not sure if it really is a bug. UVs are supposed to stretch along with images if they change aspect ratio as explained in this unrelated question

Brecht Van Lommel (brecht) closed this task as "Archived".Sat, Mar 18, 3:52 PM
Brecht Van Lommel (brecht) claimed this task.

Yes, this is not a bug though the behavior is somewhat confusing. The Correct Aspect option works based on the image texture assigned to the mesh and visible in the 3D viewport, which is done through the material. For Cycles, the image shown in the image editor is decoupled from that.