GPU/CPU difference when rendering with 1spp
Closed, ResolvedPublic

Description

System Information
win7-x64/gtx670

Blender Version
Broken: latest master ( tested with buildbot 9d873fc ) / 2.78 / 2.77 / 2.76
Worked: 2.69

GPU render produces black dots on a very simple scene when rendered with 1 spp

cpu seems fine here.

Asked on irc for a repro @mathieu menuet (bliblubli) had dots on a cpu but not gpu, @Hristo Gueorguiev (nirved) had no issues what so ever...

[edit: oops wrong john]

Details

Type
Bug
Lukas Stockner (lukasstockner97) triaged this task as Confirmed priority.Mar 19 2017, 12:05 AM

This is most likely a precision issue in the triangle intersection code.

I can reproduce some background pixels along the diagonal on the GPU (GTX 780), more of them on the CPU with AVX2 enabled, and no background pixels on the CPU without AVX2. That also explains why only some people can reproduce the issue.

If anybody else wants to test AVX2, just set the debug value to 256 (using the --debug-value argument or Ctrl+Alt+D), go to the debug panel in the render settings and disable AVX2.

CCing @Sergey Sharybin (sergey) since he fixed similar bugs in the past iirc.

LazyDodo (LazyDodo) closed this task as Resolved.Apr 5 2017, 5:49 PM
LazyDodo (LazyDodo) claimed this task.

no longer happens in master, i assume the landing of D1574 fixed it.