Collada Import messes up animations since 2.78
Closed, ArchivedPublic

Description

System Information


Windows 7 64, RX 480

Blender Version
Broken: 2.78 to 2.78c
Worked: 2.77 and before

Short description of error
When exporting the imported collada animation to fbx for a third party application like unreal engine 4 bone transforms will be messed up.
This is not related to the FBX export, only happens when the Animation was imported as collada with 2.78

Exact steps for others to reproduce the error
Import the attached dae file, check "Auto connect" during Import. Export it as fbx. this fbx is bad.
The attached fbx file is the dae file imported with 2.77 and exported as fbx. this fbx is good.
I hope comparing the bad and the good fbx will show the problem, as inside blender both appear fine, but some bone transforms are different which causes issues with the bad fbx when applied to a skinned mesh.

Details

Type
Bug
Vuk Gardašević (lijenstina) changed the title from "Collad Import messes up animations since 2.78" to "Collada Import messes up animations since 2.78".Mar 23 2017, 9:01 AM
Vuk Gardašević (lijenstina) edited the task description. (Show Details)

Could you please check if this problem also happens with the daily builds? I have fixed an Importer Bug some days ago. I suspect that my recent fix also fixes this issue here.

Sergey Sharybin (sergey) closed this task as "Archived".Jun 9 2017, 11:37 AM

Well more than a week without reply. Closing due to the policy of the bug tracker.

Will be reopen when requested information is provided.