Page MenuHome

Cannot scale textures in compositor
Closed, ResolvedPublic

Description

System Information
Windows 7 and 10

Blender Version
Broken: 2.78c
Worked: (optional)

Short description of error

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
Create a new texture in the texture tab. Make the type noise. Open the compositor, add a Texture node, select the noise texture, connect Texture node to a scale node and the scale node to a viewer node. Adjusting the X and Y values have no effect on the texture. Other texture types(distorted noise, marble, etc) can be scaled along X, but not Y.

Details

Type
Bug

Event Timeline

Hi Dwight,

the noise texture uses a randomizer for generating the noise; this makes it not consistent at all to do scaling etc. This is by design.
If you need to scale a noise typically you would be using Clouds or Distributed Noise. Or you should use an pre-calced image

Jeroen

Jeroen,

If that's the case, okay. But, this was possible in version 2.73a. I don't know when this changed. But here's a tutorial where it was still working: https://www.youtube.com/watch?v=Ra-E0JVkXEI

Thanks,
Dwight

Change of behaviour is probably relative to a fix in compositor.

You can benefit of auto-regeneration of noïse texture at each frame and scale it by adding a corner pin node between texture node and scale node.
So, I would not say that change is annoying.

Aaron Carlisle (Blendify) closed this task as Invalid.
Aaron Carlisle (Blendify) claimed this task.

Closing because this is intended behavior as pointed out by @Jeroen Bakker (jbakker)

Closing because this is intended behavior as pointed out by @Jeroen Bakker (jbakker)

If anyone wonders why I'm not a member of the Blender Cloud, look at this rude, condescending post. It took you a over a month to be a dick. This is why professionals don't use Blender. Great explanation why this was changed. I love both you and jbakker's work. You are wonderful artists.

Aaron Carlisle (Blendify) reopened this task as Open.
Aaron Carlisle (Blendify) triaged this task as Confirmed, Low priority.

@Dwight Martin (dwightmartin) thank you for your concerns, we have been a little short-handed as far a people to work on the bug tracker but after your comment, I went back and looked and the different Blender versions and also have a few questions. @Jeroen Bakker (jbakker) I can you, as the compositing expert, explain your reasoning a bit more? I went back and checked Blender versions 2.73a to master and found the issue only started appearing after 2.77. I also checked the release logs (both user and bug fixes and did not see anything that obvious as an intended change) I am also CC'ing @Sergey Sharybin (sergey) as most of the changes done in this time period were your own.

Scaling down can not work within the current compositor design. Fixing this issue would mean changing the design completely, which is out of the scope of the bug tracker.

Added note to our TODO list tho.

Thanks for the report, but this is something we have to live with for now.

Sergey Sharybin (sergey) closed this task as Archived.May 18 2017, 9:15 PM
Sergey Sharybin (sergey) claimed this task.

@Aaron Carlisle (Blendify), so "squished" part i think we can investigate (as in "resolution" if you wish).

But the aliasing we can't fix.

So basically will try to bring behavior back to what is used to be.

Sergey Sharybin (sergey) closed this task as Resolved.May 19 2017, 11:00 AM

Brought behavior back to how it was before. But i find this all weak, and some cleaner design (which follows artists' expectations instead of dictating them how to use something) is really needed in compositor.