2.8 bugs
Closed, ArchivedPublic

Description

Hi,
I'm testing the new 2.8 version dowloaded today.
I installed it in 2 different computers.
I report some bugs:

System Information
Operating system and graphics card: WINDOWS 8.1 with no. 2 GTX770 (4GB RAM) and iMAC 21"

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen) ù

  1. blender-2.80-bcd95db-win64
  2. blender-2.80-bcd95db-win64-vc14
  3. blender-2.80-bcd95db-OSX-10.6-x86_64

Worked: (optional)

Short description of error
a) In all version using Cycles it is not possible to render objects. The result is a transparent background. No object can be rendered.
b) If you add a new material the preview is black.
c) in MAC version (3) the nodes in Node Editor have some graphic problem: the text are out of the frame!!!!
d) in MAC version Clay and Eevee rendering engines crashes when selected.
e) In Windows versions using CLAY rendering engine, the MATCAP configuration are not rendered neither in OpenGL
f) Eevee rendering engine shows a black view and black objects and can't render any image.
g) Can't understand what is the "Collection" tab in the Property Editor. Using Cycles, there is just a penel (Object Mode Settings) with "Wire" and "Backface Culling", witch don't affect any change. In Clay, the MATCAP panel affect the 3D view but not the renders.

I followed the Pablo Vazqez Video. About this, I'd like to understand also:
a) The U.I. will remail the same? I saw online a mokup...
b) Pablo told about improvements, as "Override" and "Depsgraph". What about?
c) How to find information and documentation about the use of Eevee and Clay?

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
I suggest you to don't change too much the UI. This can be a real trauma for many people.

Thank you so much.
Andrea

Details

Type
Bug

Rendering a cube in viewport (SHIFT + Z)

Rendering the cube F12

Eevee... and now?

Rendering the cube in Clay F12. The cube in withe and the matcap golden

Rendering the cube in OpenGL

This mockup is a joke or Blender will be like this?

Thanks for the feedback @Andrea Coppola (blenderhighschool)! What GPU does your iMac have?

c) in MAC version (3) the nodes in Node Editor have some graphic problem: the text are out of the frame!!!!

Try latest build, I was working on this a day or two ago. (see T51086)

d) in MAC version Clay and Eevee rendering engines crashes when selected.

This is expected behavior. These new modes assume modern OpenGL is available (not true on Mac or Mesa). When we finish the OpenGL upgrade these will work on all platforms. (see T49012 and T49165)

This mockup is a joke or Blender will be like this?

Any mockup represents what someone thinks the UI could be. It gives devs & users something to look at and discuss. We don't implement mockups without critiquing first. (see T51021)

Aaron Carlisle (Blendify) closed this task as Archived.Apr 16 2017, 9:26 PM
Aaron Carlisle (Blendify) claimed this task.

Closing because of no reply.