Blender Cycles baking's margin overlap if multiple meshes are selected
Closed, ArchivedPublic

Description

System Information
Ubuntu 17.04 and GTX 1070

Blender Version
Blender 2.78.4

Short description of error
I have unfolded the UVs of all my assets with Texture Atlas to bake a lightmap. If I bake with Cycles and have multiple meshes that bakes on the same image Cycles will bake the meshes one by one at the sample set but will overwrite the previous baking with his margin because he loses the information of the UV placement of the other meshes. The only temporary way to avoid that is to reduce the margin and to increase the separation between each UV to avoid overlapping or to duplicate and join every assets to bake the lightmap.

Exact steps for others to reproduce the error
Use two meshes seperated that share UV space, if the margin is higher than the UV separation the most recent mesh baked will overlap the others.

Details

Type
Bug
Danyl Bekhoucha (linko) edited the task description. (Show Details)
Danyl Bekhoucha (linko) edited the task description. (Show Details)
Aaron Carlisle (Blendify) triaged this task as "Incomplete" priority.Apr 15 2017, 10:52 PM

Please add a blend-file that can be used to reproduce the issue.

Fable Fox (fablefox) closed this task as "Archived".May 4 2017, 8:02 AM
Fable Fox (fablefox) claimed this task.

No news in over a week... closing