Page MenuHome

HDR black pixels with buildbot releases only
Closed, ResolvedPublic

Description

System Information
Suse Leap 42.1
NVidia GTX 560ti (official drivers)

Blender Version
Broken: seems to be all 2.78 (linux x86_64 glibc 2.19) buildbot versions at least as far back as Sep 27th 2016 (7f76f6f).
Worked: buildbot 2.77 from Aug 25th 2016 (d99c513)

Short description of error
Bit of a weird one as the official releases don't have this issue.

  • any pixel in the UV/Image editor above ~9000.0 displays as black with a CM value of 0.0
  • same problem with imported high dynamic range .hdr/.exr files or internally rendered scenes
  • issue goes away after changing the colour management Display Device from sRGB to any other option

Exact steps for others to reproduce the error

  • download and open in the image editor:

  • result:

  • alternatively, an emit shader to RGB value of 1.0, 1.0, 1.0 and emit to >9000.0 and render

Edit1: issue was also confirmed by a user in #blendercoders with one of their personal builds on Debian

Edit2: the problem also goes away if the custom filmic ocio files are used: https://github.com/sobotka/filmic-blender

Edit3: It doesn't actually fail at a specific pixel threshold, but alternates. Can be tested by additive painting on a blank image with (20001.0f) background


Details

Type
Bug

Event Timeline

Aaron Carlisle (Blendify) triaged this task as Needs Information from User priority.

The only thing that I think that could have caused this is rB6fb874369c31649de7232235b0114344bfdb8e92 @Paul R (intracube) can you try removing file colormanagement/luts/srgb_inv.spi1d and the line "from_reference: !<FileTransform> {src: srgb_inv.spi1d, interpolation: linear}" from /colormanagement/config.ocio

Confirmed. Removing the line from config.ocio is enough to fix.

For some reason, that line is missing in the recent official releases.

Aaron Carlisle (Blendify) raised the priority of this task from Needs Information from User to Confirmed, Medium.

This is a bug in OCIO's interpolation code which i've submitted a pull request for [1].

I went ahead and compiled fixed version of OCIO for Linux release/buildbot environment and the builds seems to be working fine. Before i poke rest of platform maintainers, do you mind giving it a good test?

[1] https://github.com/imageworks/OpenColorIO/pull/444

Paul, can you test this with your image? I will try if I can get a window when I am near a box.

@Sergey Sharybin (sergey): Let me know when you are happy with it and I will poke Mr. Cooper to get it pushed quickly.

@Troy Sobotka (sobotka), there is actually another fix for the same issue which predates mine by like 12 days [1]. It solves similar issue. Personally, i do not care which fix goes in -- they should both work the same. If you can poke someone and help getting any of the fixes to the upstream it'll be great.

[1] https://github.com/imageworks/OpenColorIO/pull/441

How are you performance testing the lookups with the viewport? I have a few tests I would like to try with a degree of certainty.

@Troy Sobotka (sobotka), all the stuff which is not directly related to this bug please save for ML or IRC.

Paul R (intracube) added a comment.EditedApr 18 2017, 11:03 PM

@Sergey Sharybin (sergey) looks like the latest linux builds are fixed.

Have just created an exr gradient animation which ramps up to 30000.0f - no sign of glitches

Edit: and some spot-checks up to much higher values. Still all good.

Sergey Sharybin (sergey) closed this task as Resolved.May 15 2017, 4:34 PM

Asked platform maintainers to update OCIO library [1].

Nothing else we can do here in the bug tracker, just need to give maintianers bit of a time to update libraries and poke the builders.

[1] https://lists.blender.org/pipermail/bf-committers/2017-May/048367.html