Menu flickering under wayland unless "Window Draw Method" is set to "Full"
Closed, InvalidPublic

Description

System Information
Kernel: 4.9.22-1-MANJARO x86_64 (64 bit)
Desktop: KDE Plasma 5.9.4
Distro: Manjaro Linux
Graphics Card: Advanced Micro Devices [AMD/ATI] Juniper XT [Radeon HD 5770]

Blender Version
Broken: 2.78c e92f235283

Short description of error
Menu flickering under wayland.

Exact steps for others to reproduce the error
In Blender set "Window Draw Method" to "Triple Buffer"
Login to KDE/Gnome wayland session
Go to File menu(its the longest, easier to trigger) and simply move mouse pointer up and down a few times.

P.S. When are you planning to add wayland support? Thanks.

Details

Type
Bug

If Blender works properly with Window Draw Method set to Full, then this is not a bug. That is simply the setting that plays nicely with your particular graphics card + driver.

Corrections welcome. Otherwise, I'll close this later.

Bastien Montagne (mont29) closed this task as "Invalid".Jul 4 2017, 5:14 PM
Bastien Montagne (mont29) claimed this task.

We do not have to "support" Wayland afaik, this is low level compositor API that is hidden to most applications behind higher level APIs…

Anyway, this sounds more like driver issue (are you using official AMD ones?) than anything else.