Page MenuHome

Replace placeholder "Force" and "Group Instance" icons in Add menu with custom icons
Closed, ResolvedPublic

Description

I've made new icons for the "Force" and "Group Instance" items in the Add menu.

(Ignore the node icons; that's for a separate task.)

Details

Type
Bug

Event Timeline

Brendon Murphy (meta-androcto) triaged this task as Normal priority.

hi, thank you for creating these icons.]
Currently the Force menu & Group Instance menu are using the "EMPTY" icon, which duplicates the icon 3 times in the same menu.
I think this is very important to fix as the add menu is one of the first menus users look at & we need to have the ui represented well at this level.
After discussion with @Julian Eisel (Severin) in irc it was suggested to be effective we needed to create some new icons matching the Force Fields & Group icons in the same color tone as the Add menu icons.
I had asked @Jon Ross (zlsa) if he was able to create such icons & we now submit this task.
This is not a small issue & quite honestly I consider it an UI bug that the icons are not well represented.
If we can commit the new icons, it's a simple 2 word fix to change the current mismatched icons & solve the issue. Which I will be more than happy to commit.
Thanks

IMO I prefer the alternative force icon. To me, the other just looks like two blobs mashed together.

Aaron Carlisle (Blendify) raised the priority of this task from Normal to Confirmed, Medium.

The group icon is fine. For the force icon I would take the one from Force, and change colors to the orange ones like the rest of the icons in the add menu. Alternatively it can be a little sphere with arrows going out of it in the top bottom left right directions, or something like:

I didn't want to use the Force Point icon because it's a specific kind of force, while the other icons show the object data, not any particular kind of object. I'll try out the recolored Force Point icon, as well as the "waves" concept you've made.

For me the last alternative you have outlined is good, although it is radial the circle is not closed and can be interpreted as general. I leave some ideas, I personally like the arm, shape is complex but the silhouette is very recognizable, on the other hand it is generic and because it is also in WhatsApp the association is also fast. The boxing glove looks like a cloud.

hi, I think time is short to get this done.
The icons should be removed if we cannot find suitable replacements. Currently the duplicate icons look unprofessional.
As the two menu's are at the last slots on the menu, this has less impact on the menu & at least removes the wrongly assigned icons.
If we get the icons replaced suitably in time for 2.79 release, it would be great.
My proposal would be to remove the duplicate icons before bcon3, then repopulate during bcon3 if this task gets completed..

I've added two more icons:

Which one of {Alt 2, Alt 3} is preferred?

I like alt 3, alt 2 looks like the normal force icon.

Alt 3 for me. It's the most immediatelly recognizable and different enough from other icons in the Add menu.

And good work on the style, the new icons fit very well.

Do we also agree on the node changes?

Jon Ross (zlsa) added a comment.EditedMay 4 2017, 5:54 PM

Those are icons I changed for myself, and they look quite different compared to what's currently in Blender. I'm fine with them being added at the same time, but I'd like to get more feedback first.

Albert (wevon) added a comment.EditedMay 4 2017, 8:11 PM

I think Alt 3 is correct although compared to the initial icons, the outline should be brown, not black or gray.
Anyway I added a couple of proposals adjusted to the style of the icons of Blender.
My vote is for Alt 5 :)

I don't know if this is relevant but avoid any conflict, I inform you I have created a new outliner icon for new grease pencil object using icon_120 with OUTLINER_OB_GPENCIL name.

You can see the icon in greasepencil-object branch

ALT_3 looks ok, though a bit like it's emitting sound not wobbling. This could alleviate that:

@Antonio Vazquez (antoniov) I believe that will need to be manually merged, but you'll only need to copy/paste the changed icons (so it won't be a giant mess.)

I've made a three-sided icon in the same style (Alt 4), along with two variants of a smaller, more vibration-like (Alt 2 and 3.)

Which one do you prefer?

hi, I think time is short to get this done.
[...]
My proposal would be to remove the duplicate icons before bcon3, then repopulate during bcon3 if this task gets completed..

I don't see why we would have to rush this too much, replacing an icon is a minor change that can be done in Bcon3 too (@Campbell Barton (campbellbarton), you agree?).


Which one do you prefer?

I like ALT 4 here, I think it works fine. Regarding the new NODE_SEL - its orange tint breaks the color code of using orange icons for mesh types, I'd prefer if it looked more like an orange outline.

Note that for the final commit we need the icons as .svg files.

It's tangentially connected to this task but there is a lot of duplicate icons in modifiers too.
MOD_MESHDEFORM is used 5 times.

@Julian Eisel (Severin), it's all SVG. The node icons are just in that file but aren't part of this task, but I'll change the color scheme.

@Vuk Gardašević (lijenstina), I can make more icons after this. These icons were suggested by @Brendon Murphy (meta-androcto).

So, do we all agree that OUTLINER_OB_GROUP_INSTANCE and OUTLINER_OB_FORCE (ALT 4) are fine? If so I'll go ahead and commit them.

That means I need the icons as .svg now, images above are all .png or .jpg.

Sorry, I've been busy. Here are the two icons as SVG:

So, do we all agree that OUTLINER_OB_GROUP_INSTANCE and OUTLINER_OB_FORCE (ALT 4) are fine? If so I'll go ahead and commit them.

Looks OK to me.

Julian Eisel (Severin) closed this task as Resolved.Jun 10 2017, 4:50 PM

Committed rB0dd6e5bfee3de. Thanks all!