Page MenuHome

Use Draw Manager for OpenGL Render
Closed, ResolvedPublic

Description

Currently the legacy viewport is used for OpenGL render even when rendering from view-ports using the draw-manager.

Details

Type
To Do

Event Timeline

Dalai Felinto (dfelinto) lowered the priority of this task from Normal to Confirmed, Low.

Committed rB3f567535da163df7e77fe9438cc80fb8b2c67b87, but leaving open since Eevee isn't working yet (gives some graphical glitch).

Update, the problem with Eevee is caused by multi-sample buffers. Disabling Anti-Aliasing works.

Campbell Barton (campbellbarton) closed this task as Resolved.EditedMay 2 2017, 9:13 PM

Closing, since the feature is working now. Eevee support for AA is worth supporting but more some corner-case.

We could have a way for engines to force full-samples if they dont support multi-sampling.