Page MenuHome

Objects displaced randomly (moved and rotated) after saving work file in .blend
Closed, ResolvedPublic

Description

System Information
Windows 10 v16076 on
AMD phenom II x4 955 3.2Ghz + 8Go RAM
GFX: with Nvidia GT720 driver: 21.21.13.7653 +1Go

Blender Version
Broken: 2.78c - 2017-02-24 - Hash e92f235283
Worked: 2.75

Short description of error
------Objects displaced randomly (moved and rotated) after saving work file in .blend --------
Some objects are moving and rotating randomly when i re-open blender content saved file.
That's a crazy mistake for this PRO project, i'm in down way coz i've to repair always my saved file with this moved objects..
then i exported in .obj and re-import: this was OK .. nothing moved .. but then.. it re-appears till i saved normally in .blend !! shame.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
1 -- just move the "door moves alone_1" objet (sort of door in form of U).. rotate or move or the 2nd object "roof_moves_alone" which appears to have moved on test2 when i just move "door " !!!
1 bis -- just save file and re-open : objects (but not all) may have moved

Here to this file is before and after (on right) saved file !!
with marked points

2 -- i've put object "Door_moves_alone_1_repere" , which is a mark inside the "door moves alone" object that you see the effect.
3 -- i also saved a last time the file in .blend to upload for you: i screenshot it (Bug_mover_stade3.png) that when you open the file, you may see the moved objects ! as is

I expect you find something i did wrong, may be an add-on ? And thank you all ! and if you say when the error is found cheers !
AkoZ

Details

Type
Bug

Event Timeline

Ako Zoom (AkoZ) triaged this task as Confirmed, Medium priority.
Aaron Carlisle (Blendify) raised the priority of this task from Confirmed, Medium to Needs Triage by Developer.May 2 2017, 2:59 AM

There are currently location + rotation keyframes on some of the objects (frames 0 and 33). Try removing all keyframes before fixing the position of all the objects.

From the file, it's not possible to tell if these keyframes were introduced by the Archimesh addon or not. From I can tell, I'm guessing that these were probably added accidentally?

Ako Zoom (AkoZ) closed this task as Resolved.May 2 2017, 10:33 AM
Ako Zoom (AkoZ) claimed this task.

Yeeahhh a big thank YOU Joshua !

I delete all that keyframes, came from automatic keyframing .. and it seems to be all OK!
Excuse all for the bothering of your really great work on 3D blender (i 'm on it since its start !.. so about 20 years to use it slowly and now for production).
Best Regards for the good organized team it is now !
AkoZ