Snap to high-res mesh unknown bug
Closed, ArchivedPublic

Description

System Information
windows7 64
ASUS ATI Radeon HD6870

Blender Version
Broken: (All)
Worked: (None)

Short description of error
this is very strange behavior.
1st time i was activate this bug with sculpting
2nd time i was add hi-res model, and try to snap - bug will active
create hi-res model


draw anything, create relief

smooth this model

add any other object to this scene, go to edit mode, try to snap to this sphere(vertex,edge, face - is not important) and we will have incorrect snap

Exact steps for others to reproduce the error
open this file


press G to grab, try to snap to sphere - we will have incorrect snap

Details

Type
Bug

There is no bug, here.

You specified VERTEX as snap element target.
So, your selected vertex is snapped to vertex of high poly mesh closest to your cursor from choosen point of view.

When cursor is pointing to a face on visible front side of high poly mesh ; from choosen point of view, a vertex of hidden backside of your mesh can be closest to pointer than a vertex of face where is placed pointer.

You just have to be consistent and choose FACE as snap element to snap a vertex on visible front surface to avoïd problems.

Snapping to vertices on backside of model does not make sense to do retopology of a high poly mesh.
But it can be really helpful in regular low-medium poly mesh editing in wireframe mode.
So, current behaviour of VERTEX as snap element is consistent in many other contexts.

So, please use the tool appropriate to the context.

This comment was removed by Alexey (Inwader77).

i was repeat this error with faces too.
but we have strange behavior:
if we save, close and open again - working will properly

save and revert - working properly too.
working with bug only without save

I tried on a not-saved file and I see no bug. I don't see any reason in this case how not saving the file could influence snapping.
The problem is more that snapping doesn't respect the 'limit to visible' toggle of selection mode.
I think @Germano Cavalcante (mano-wii) wrote a patch for this, not sure if it's ready for release? Will let you decide on this one.

Germano Cavalcante (mano-wii) closed this task as "Archived".Jun 5 2017, 1:08 AM

Tha sanp in blender still does not support occlusion (ignoring elements that are behind faces).
Blender 2.8 will bring some changes to the mesh mapping that will influence the snapping code. The implementation of occlusion test can be thought of in a more efficient and simple way when this change in the meshes has been implemented.

Added to TODO list:
https://wiki.blender.org/index.php/Dev:Source/Development/Todo/Tools#Transform_Snap