Incorrect windows scaling - mouse offset from view - menu bar invisible
Closed, InvalidPublic

Description

System Information
Windows 10 (1703)
Intel 7th gen HD graphics
Intel and Lenovo display drivers behave the same.
Lenovo ThinkPad Yoga 370 Intel Core i5 7th gen.

Blender Version
Broken:
2.68a 64 bit,
2.75a 32 and 64 bit,
2.77a 64 bit,
2.78c 64 bit,
2.78 f3d9f0c 64 bit both standard and the experimental vc14 compilers,
2.80 branch f637145 64 bit.

Worked: (I cannot find a version of Blender from the last few years that works with the latest Intel drivers!)
It works if I revert to an older version of the Intel HD drivers for 7th gen as suggested by @Dragon (someDragon).
Intel drivers version 15.45.16.4627 previous release 23 March 2017, works.
Added to the Intel developer support forum:
https://software.intel.com/en-us/forums/graphics-driver-bug-reporting/topic/735289#

Short description of error
Window layout does not fit the screen. The title bar appears to overlay the top menu bar. The positions are all offset like the graphics on display are a different size to the internal calculations. The mouse pointer needs to be a few millimetres under the screen button to be able to click on it!
The image attached best describes the issue. Note that there is no menu bar visible and the side bar is partly outside the window edge.

Exact steps for others to reproduce the error
I suspect it is a specific hardware combination that causes the issue. 1920x1080. I've tried both the Lenovo and the Intel versions of the display drivers.
By default I have the Windows 10 display scaling set to the recommended 150% however I have tried changing the scaling to 100% and the behaviour of Blender is unchanged!

Details

Type
Bug
There are a very large number of changes, so older changes are hidden. Show Older Changes

Please try the latest build from here, there have been some DPI improvements for 2.79 that might help.
https://builder.blender.org/download/
https://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.79/UI#Automatic_DPI

@Brecht Van Lommel (brecht) thanks for the suggestions.
None of them were any different, they all had the same problem with the window being partially under the title bar and the mouse pointer being offset!
I've now tried:
2.78 f3d9f0c both standard and the experimental vc14 compilers
2.80 branch f637145

Good afternoon.
I have exactly the same problem on my new laptop.
Also tried different builds, very old and new ones from graphicall.org.

I attached the system-info.txt file.

I also removed the manufacturer graphical display drivers and let Windows 10 install them again automatically. No change.
Then I let the Intell installer install the latest drivers. Still no difference.

Just tried the https://builder.blender.org/download/ version. Same problem.
See sys-info.txt

@Nico Bunk (NicNic) good call on the system-info.txt file. I've attached the same from my system.

The bit that stands out to me is that the graphics are from the 7th gen processors:
renderer: 'Intel(R) HD Graphics 620' (and your's is 630)
vendor: 'Intel'
version: '4.4.0 - Build 21.20.16.4664'

What is the exact make and model of the computer you are using?
I would guess, it has a 7th gen Intel processor in it.

The Intel(R) HD Graphics 630 and 620's are built in to the latest generation of the Core i7 and i5 processors. More and more people will get those when they buy new computers.

@John Brown (jcbdigger), You are right about the processor (Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz / Intel(R) HD Graphics 630). This info is also in the system-info.txt, near the end.

I'm having the same issue with an (also 7th gen) Intel Pentium g4560 desktop CPU (Intel HD Graphics 610). Also on Windows 10. For me, using these older drivers seems to fix it for now.

@Dragon (someDragon) Thank you. I've deliberately tried the previous release drivers rather than the Beta drivers and they also work.

Intel HD Drivers for 7th gen:
Working
15.45.16.4627 previous release 23 March 2017
Beta 15.45.4614 dated 23 Feb 2017

Not Working
15.45.18.4664 latest release (at time of writing) 3 May 2017

I will attempt to report this to Intel.

15.45.16.4627 is also working here!
Thanks all for now!

Hope Intel will fix it in the future.

Aaron Carlisle (Blendify) closed this task as "Invalid".May 30 2017, 8:16 PM
Aaron Carlisle (Blendify) claimed this task.

Because this is a driver version there is nothing we can do. Closing.

Hello
As a temporary fix you can force blender to run on your GPU (if you have one). This resolves the issue

(DELL XPS 9560 with 4K display)

I had the same problem on a new Dell Precision laptop. I downloaded Blender 2.77 windows 64 and everything is working correctly.

Update: I was wrong. 2.77 is not operating correctly

Fixed!

Had the same problem on a Win10 x64 Lenovo X1 Yoga with Intel HD Graphics 520. The 5/17/2017 21.20.16.4678 drivers seemed to break the UI.

However, I just updated to the 8/13/2017 22.20.16.4771 drivers and the issue is fixed. Edges of the UI are no longer cut off and the mouse alignment is corrected.

I'm also having this issue on Win10 x64 Lenovo X1 Yoga (2nd gen) with Intel HD Graphics 620. In the entire time I've had my laptop (since June 2017) I have had this issue.

I can't seem to find the correct driver version that MattPenner mentioned on Intel's site. Can someone share a link?

T (voxelv) added a comment.EditedMon, Sep 4, 6:18 AM

I guess the Intel HD 620 Graphics has a different number (of course haha).

It wasn't as straightforward to install on the Lenovo ThinkPad X1 Yoga (2nd Gen) though. It kept saying something to the order of "This driver is not approved for your computer by its manufacturer" and wouldn't install.

EDIT: (I forgot the link): https://downloadcenter.intel.com/download/27058/Graphics-Intel-Graphics-Driver-for-Windows-15-46-?product=96551

In case others come here looking for a solution on the 2nd Gen, here's the steps I took:

  1. Open Device Manager
  2. Right Click Display Adapters -> Intel HD Graphics
  3. Properties -> Driver tab -> Update Driver button
  4. Use the "List of drivers on my computer" option
  5. Set to Microsoft Basic Driver. Note, your graphics may now be quite wonky because they aren't using the GPU...
  6. Install the new driver from Intel.
  7. Reboot.
  8. Done!

@T (voxelv) it is quite common for laptop vendors' drivers to warn that chipset manufacturer drivers are not approved.
The slightly tidier way, to achieve the same as you have described, is to completely uninstall the laptop vendors' drivers and then install a clean set of drivers from the chipset manufacturer. Intel in this case.

Regards

I have religiously stayed with the Lenovo System Update Utility just because I've ran into issues in the past (namely with Windows 8 and Miracast drivers) where reference drivers were incompatible compared to the vendor drivers.

However, in this case Lenovo was happy to tell me my system was up to date, and even wanted to suggest a different graphics driver when it noticed I had the reference driver loaded. So, I'm ignoring the System Update Utility for my graphics for the time being.

My update actually was a much easier process than described above. Not sure why. I went to the Device Manager, Display Adapters, right-clicked on my Intel(R) HD Graphics 520 device and selected Update Driver Software. Not sure where Windows looks compared to Lenovo but it loaded the Intel driver and all was fixed. Strangely as I mentioned above I have driver version 22.20.16.4771, yet the Intel website states 15.46.05.4771 is the latest.

@T (voxelv) and @Matt Penner (MattPenner) I take back what I said. My Lenovo was a pain to update. The new drivers kept claiming they did not support the operating system I was using.
Uninstalling the previous drivers kept reverting within a few seconds to an older version of the Intel drivers!

Thank you @T (voxelv) your method worked.

Regards

Sadly the new drivers no longer work in conjunction with a DisplayLink adaptor.
Previously, as long as I had the lid to the laptop open, I could use Blender on one of my external screens connected to a USB 3 DisplayLink dock.

Now Blender will only render on the laptop screen!

Disappointing.

I can confirm that rendering still works while using the ThinkPad OneLink+ dock, even with the laptop (X1 Yoga) closed. I've got two monitors both on DisplayPort and was able to render without an issue. I'm not sure how current the USB 3.0 dock drivers are. When my company used that with several older Lenovo X1 Carbons we had a few issues. For the most part they worked but I had to reboot weekly for the screens to show up and we had a couple that just died unexpectedly.

@Matt Penner (MattPenner) the OneLink+ connector is unique to Lenovo's as far as I know. Whereas DisplayLink is a chipset embedded inside nearly all USB 3 docks. It's advantage is that it works with nearly any laptop, the disadvantage is that it needs display drivers on the PC and these are not as powerful as the Intel HD chipset.
The DisplayLink based docks are OK for most corporate business uses but not optimised for graphic intensive applications.
At home I can just use a direct connect cable but at work that's not so convenient!