Page MenuHome

OpenAL Issue
Closed, InvalidPublic

Description

System Information
Windows 10 x64

Blender Version
Broken: 2.78c

Short description of error

AL lib: (EE) LoadHrtf: Could not open default-44100.mhr
AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 192000hz instead
AL lib: (EE) LoadHrtf: Could not open default-192000.mhr
AL lib: (EE) GetHrtf: Incompatible format: Stereo 192000hz

Exact steps for others to reproduce the error
Open Blender.
Wait as it appears in startup System Console.

I have tried searching before posting this to see if anyone else had this problem, but to no avail. All I can find is other posts with only the second line, none including the 'Incompatible Format' line. I have also already tried everything that @Julian Eisel (Severin) said to do in T44416 and none of it fixes the issue. Also, it doesn't matter what I set in my user prefs as all settings (except for SDL) will cause this error message to occur. I have the most current drivers across the board so I am pretty sure it is not something on my end, but I could be wrong. It doesn't seem to affect any use of audio in blender but I just might be noticing something. Other than that, it's more about the error message appearing every time I start up Blender being annoying.

Details

Type
Bug

Event Timeline

Aaron Carlisle (Blendify) triaged this task as Needs Information from User priority.

In order for us to be able to reproduce we need files that are failing.

What files are you needing because this occurs regardless of what is used. Doesn't matter if it is a factory clean install or not, a first run or a load.

Does this actually affect your audio output? The messages don't sound like they would affect audio working.

To me it sounds like you have a wrong OpenAL soft configuration. Blender for sure doesn't use the OpenAL functions LoadHrtf and GetHrtf.

It doesn't seem to as I tested it before creating this (as far as I can tell anyways). As for the rest, if my system was linux, I could check that to see, but I don't think there is a configuration for a windows system. As for the functions, I've only ever seen those errors from Blender.

Of course windows also can be configured. You have to edit the file %AppData%\alsoft.ini

If you want to get rid of the errors try the following configuration:

[general]
hrtf = false
frequency = 192000

See further configuration options here: https://github.com/kcat/openal-soft/blob/master/alsoftrc.sample

Didn't know about that file, though I wasn't expecting it to be outside of a folder. Anyways, I made the change and all that happened is that the error changed, but still exists.

AL lib: (EE) LoadHrtf: Could not open default-192000.mhr
AL lib: (EE) LoadHrtf: Could not open default-192000.mhr
AL lib: (EE) GetHrtf: Incompatible format: Stereo 192000hz

Did you also open a sound file and try to play it? For example in the video sequence editor? If it works, you can just ignore those messages...

That's always seemed to work. Just with the error messages occurring, I figured something could be wrong that I couldn't notice.

Joerg Mueller (nexyon) closed this task as Invalid.May 22 2017, 11:51 AM

As long as the sound works, I'm fine :)

There's probably nothing we can do about this error if explicitly turning hrtf off in the config doesn't work. Maybe that's a bug in OpenAL soft, but as it doesn't bother much, I would just ignore it. I quickly checked the OpenAL soft bug tracker and found some similar issue there, maybe a future update of the library will get rid of the error.

Alright. Thanks for helping.