Page MenuHome

Renaming numbered bones in Outliner does not re-order them alphabetically
Closed, InvalidPublic

Description

System Information
Windows 8.1 64 bit; EVGA GTX 970

Blender Version
Broken: (2.78c e92f235283)

Short description of error

Hi all, I just came across a bug in the outliner. I have 6 bones in an armature each parented (keep offset) to a main bone. When I rename the bones, (ie. Bone_4 > Bone_1) the visual position in the outliner does not change, despite "Sort Alphabetically" being checked. This results in a visually disjointed hierarchy, (ie. 4, 3, 5, 2, 6, 1; instead of 1, 2, 3, 4, 5, 6). Clearing the parent and re-parenting doesn't update them either, which is strange.

Thanks for looking into this.

-Adam

Details

Type
Bug

Event Timeline

I had to trick it by separating all the bones into their own individual armatures then re-combining them one by one back into the original armature. This worked good since I had only 6 bones affected, however, it would be quite tedious if a large number of bones had to be renamed.

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but no bug here, this is expected behavior, Outliner only sorts objects, data-blocks or vgroups. Bones are drawn in order they appear in internal storage.

Thanks, Bastien, for letting me know. I guess that would make this a feature request, then. :-) It would be great if the outliner could replicate the behavior of renaming vertex groups, except with bones. There's lots of sort options available there: you can automatically re-order alphabetically if you have "sort items by their name" checked, or, if unchecked, you can click "Sort by Name" in the vertex group specials as a 2nd step and it will update. I could see this being an extremely useful feature, as some custom-non-character rigs require many numbered bones, and in my case, the bone numbering needed to be swapped, which completely messed up the outliner. For this particular rig, I relied heavily on the outliner for bone selection and once I fixed the ordering problem, it made it a lot easier.

Thank you again for your excellent work in developing Blender.

Have a great day.

-Adam