Filter and Texture Nodes in Compositor crash Blender
Closed, ResolvedPublic

Description

System Information
Windows 8.1, Nvidia GTX 760 M

Blender Version
Broken: 2.78c e92f235283

Short description of error

Using Filter node as Image input to Scale node and Texture node as input to X and Y offsets of Scale node crashes Blender

Exact steps for others to reproduce the error

  1. Switch to Compositing
  2. Add Texture node with Clouds texture
  3. Add Filter Node with Sobel on
  4. Add Scale Node with Relative on
  5. Add Viewer node
  6. Enable Backdrop
  7. Connect Images of Texture To Sobel To Scale To Viewer
  8. Connect Texture Color output to X input of Scale node
  9. Blender crashes.

Details

Type
Bug
Rumen Belev (syziph) edited the task description. (Show Details)
Aaron Carlisle (Blendify) triaged this task as "Incomplete" priority.Jun 3 2017, 4:14 AM

Thanks for the report but it would be helpful if you add a blend-file to the report that demonstrates the issue at hand.

Do you mean like this?

Yes, that's the setup that crashes Blender.
It was mentioned from another user I just replicated it on my machine.

Thanks for the report but it would be helpful if you add a blend-file to the report that demonstrates the issue at hand.

There is no need of blend file.
The steps are clear and simple to do. Joel Godin posted picture with the correct node setup.
Interestingly he seems not to have any issues.
Maybe it's video card thing? I think the culprit could be the Backdrop option when it's on.

I have same crash with Win7 64 bit and ATI HD4670

Please try with a build from builder.blender.org/download

There is no need of blend file.

Actually next time yes please include a blend file as it took probably 20 minutes to reproduce that set up as I wasn't sure which renderer
was used, and where the nodes were.
An attached Blend would have been quicker.

Please try with a build from builder.blender.org/download

Tried with latest build
blender-2.78-420d4a7-win64

Blender doesn't crash, but the Backdrop disappears.

Decided to play with the texture node before plugging it into Scale offset

If I plug Normalize Value to X offset of the scale node, Blender doesn't crash but there is no Backdrop image (or trasparent image in the Viewer Node).
If I connect Add node and adding value of 0.3 the Backdrop appears and I see an image (see the screen shot 1)


Value of 0.2492 works too but below that it's getting ugly.
Setting Add value to 0.2 produces artifacts in the image (see the screen shot 2)

Can someone explain this behavior?

Joel Godin (FloridaJo) raised the priority of this task from "Incomplete" to "Confirmed".Jun 3 2017, 11:31 PM

I see that too, and all I have to do is go Converter > Math and it renders corrupted. Even before I hook it up.
Title maybe should be changed to "....cause corrupted backdrop image"

This is after hooking it up:

The title is based on initial observations.
It is definitely a bug so I will leave it to developers to figure it out.

I have found that the builds after June 4th address the texture to scale distortion bug.

However if I place a Directional Blur Node OR a Sunbeam Node before the scale node, Blender crashes. I am not sure if it is related or the same bug?
Mac OSX 10.11.6 Blender 2.78 Hash: f74b4a0

Sergey Sharybin (sergey) closed this task as "Resolved".Wed, Sep 13, 4:40 PM
Sergey Sharybin (sergey) claimed this task.

Since the crash and scale issues are solved, closing this report.

If you still have issues with texture nodes, please open separate bug report, including:

  • Exact .blend file which crashes (just do it, doesn't take much time for you to upload file, saves lots of troubleshooting time which often ends up in some option which seems unrelated being different).
  • Exact Blender version used to test the bug.

Additionally, test the bug with 2.79 and latest builds from builder.blender.org, there are threading issues solved every so often.