Page MenuHome

Denoising progressive refine issue
Closed, InvalidPublic

Description

System Information
OS X 10.10.5, 32gb Ram, 6core intel Xeon - mid 2010.
ATI Radeon

Blender Version
daily build blender-2.78.0-git20170603.420d4a70b8-x86_64

Short description of error
Denoising not working when render performance "progressive refine" is enabled. When progressive refine is disabled denoising works as expected

Exact steps for others to reproduce the error

Event Timeline

Joel Godin (FloridaJo) lowered the priority of this task from 90 to 50.

True here as well.

Lukas Stockner (lukasstockner97) changed the task status from Unknown Status to Invalid.Jun 4 2017, 12:11 AM

Thanks for the report, but this isn't a bug, it's simply not supported (yet).

Can we automatically grey out progressive refine when denoising is enabled, and then disable it inside Cycles for rendering? Would also be good to mention this in the release notes.

Eric Leo (stargazer) added a comment.EditedJun 6 2017, 11:12 PM

Really good idea to grey out progressive refine. Without it greyed out people will think blender is broken.

A little mention on this.
It seems confusing to me that the progressive option is greyed out with no mentioned that it is because i had denoising turned on.
My colleague suggested that maybe the denoising options should be placed in render settings under performance as well, but I see that the interface is frozen due to 2.8 and it is a larger decision which has probably already been discussed at length...
But could this at least be mentioned in the tool tip?