Page MenuHome

Blender crashes on loading specific file
Closed, ResolvedPublic

Description

System Information
Windows 10 Pro x64
Intel i7-6900K
2x GTX 1080Ti (not currently in SLI)
64GB DDR4 RAM
Running off a 500GB SSD

Blender Version
2.78c Hash: e92f235283

Short description of error


Whenever I open a particular file Blender will open the console, initialize the window, and then immediately terminate the window and the console. I have not been able to collect any error data. This file worked perfectly at the least on Friday, possibly on Monday. No internal hardware or software changes that I can recall since then.

This issue happens using 2.78c, 2.78, 2.77a etc, other files launch normally in all these versions.

Exact steps for others to reproduce the error
Open the file using any method, including double-click, open with Ctrl-O or drag-and-drop

Details

Type
Bug

Event Timeline

Win 7 64 bit / GTX 750 / Blender 2.78c

I use File-> Open and it didn't crash. It shows Camera Perspective / Preview Render.

can't reproduce either, try starting blender with the --factory-startup commandline option and see that resolves the problem.

Tested with and without Blender Sensei on latest Blender for Win64 build 2.78.5 (hash 81d7ff8) - Windows 7 64 bit

Open normally with double click on file and no crash at all... loaded perfectly!

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.Jun 8 2017, 8:46 AM
J. W. Sargent (NoviceInDisguise) closed this task as Resolved.EditedJun 9 2017, 3:24 AM

Issue has been resolved for now, I am unsure what exactly made this happen, however I am now convinced it is not a bug that can be easily replicated/fixed so a definite solution could be hard to find. For now, try running Blender from the command line with --factory-startup as recommended.

@J. W. Sargent (NoviceInDisguise) , the parameter allow Blender to run in factory setting. so the issue could be in any add on you enabled / installed or other setting if you run Blender normally. So you could try use a new zip version of Blender, and try enable add-on one by one and see which could be the issue.

However, you are correct. Its not easily replicated or fixed, specially if it involve 3rd party add-on.