Page MenuHome

Node Wrangler - Line Error
Closed, ResolvedPublic

Description

System Information
OS: Windows 7 Professional 64-bit
Mainboard: ASUS M5A78L-M LX3
CPU: AMD FX-6300
GPU: NVidia GTX 750 StormX OC
RAM: 8 GB

Blender Version
Broken: 2.78c

Short description of error
When I try to add an "Image Sequence" node to an already created and opened node group in Blender´s Compositor I receive a traceback error message with a failure in line 3066. I made sure that the folders/files have NO special characters or something in it! I googled my problem before, but I wasn´t able to find another post like this, so I decided to bring it over here.

Traceback (most recent call last):

File "C:\Program Files (x86)\Blender Foundation\blender-2.78-windows64\2.78\scripts\addons\node_wrangler.py", line 3066, in execute
  node.image = img

AttributeError: 'CompositorNodeGroup' object has no attribute 'image'

location: <unknown location>:-1"

Exact steps for others to reproduce the error
-Open up Blender (Cycles)
-Go to the Compositor
-Create any node group; in my case it was a "Color Mix" node, and the group was connected to another node
-Switch to the node group (tab in)
-Try to add an image sequence (Add, Input, Image Sequence). I used a sequence of 150 images (30 fps).

Event Timeline

Sergey Sharybin (sergey) triaged this task as Normal priority.

@Greg Zaal (gregzaal), are you the guy to poke with such reports?

Yep, thanks, will look into it.

Changing node = context.space_data.node_tree.nodes.active (line 3058) to node = context.active_node should fix that.