Workspace: Cycles material preview crash
Closed, ResolvedPublic

Description

Blender Version
Broken: 7f564d74f9edaaa41ce27c6e854869096f70b4da
Worked: 7f564d74f9edaaa41ce27c6e854869096f70b4da^

Short description of error
Cycles material preview no longer working.

Exact steps for others to reproduce the error
Change engine to Cycles, create a material in the object, show the preview tab.
or
Just open

Full backtrace: P495

Details

Type
Bug
Dalai Felinto (dfelinto) moved this task from Backlog to Workspaces on the BF Blender: 2.8 board.
Dalai Felinto (dfelinto) triaged this task as Confirmed priority.
Luca Rood (LucaRood) closed this task as Resolved.Jun 23 2017, 12:28 PM

This has been solved by 802027f3f8f9a83a77134a2b104a25ff3a4ac013

Sergey Sharybin (sergey) claimed this task.

Re-opening. The "fix" is totally unrelated and only happened to solve anything because of bug in the implementation. That bug broke something else in fact.

This is now properly fixed by rB205d750a634.

Sergey Sharybin (sergey) closed this task as Resolved.Jul 10 2017, 5:31 PM