Blender 2.78c crashes on Mac OSX Sierra (10.12 ) - every time AND immediately
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card:
Mac OS Sierra 10.12 INTEL GRAPHICS 4000 ( 2012 MacBook Air )

Blender Version
Broken: 2.78C build 14 june 2017

Short description of error
HANGS ON STARTUP or short after / hides interface ( panels disappear spontanouisly )

Exact steps for others to reproduce the error
just download an start Blender

Details

Type
Bug

Blender 2.78c, and any previous version for that matter, also hangs on iMac OSX Sierra right after start-up.

Could you start Blender from terminal and tell us what console output looks like?

Vuk Gardašević (lijenstina) renamed this task from Blender 2.78c C.R.A.C.H.E.S on MAC osx S.I.E.R.R.A ( 10.12 ) ----- every time AND immediatly to Blender 2.78c crashes on Mac OSX Sierra (10.12 ) - every time AND immediately .Jun 15 2017, 4:58 PM
Vuk Gardašević (lijenstina) updated the task description. (Show Details)

Blender crashes instantly on my computer too. Here is the Terminal output:

Color management: display "sRGB / BT.709" used by scene not found, setting to default ("sRGB").
Color management: scene view "Filmic Log Encoding Base" not found, setting default "Default".
Color management: scene look "Base Contrast" not found, setting default "None".
Color management: sequencer colorspace "sRGB EOTF" not found, will use default instead.
Read new prefs: /Users/danial/Library/Application Support/Blender/2.78/config/userpref.blend
found bundled python: /Applications/blender.app/Contents/MacOS/../Resources/2.78/python
addon not found: 'io_import_scene_mhx'
measureit: Imported multifiles
archimesh: Imported multifiles
blender(2937,0x7fffd539a3c0) malloc: *** error for object 0x10f519cc0: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

@Danial (Danial) What is your default scene? Run blender --debug --factory-startup and see what is outcome of that.

Bastien Montagne (mont29) triaged this task as Incomplete priority.Jun 16 2017, 4:46 PM

@Danial (Danial) What is your default scene? Run blender --debug --factory-startup and see what is outcome of that.

My default scene was simply a camera and lamp. Running the terminal with the additions you said results in this output...

Switching to fully guarded memory allocator.
Blender 2.78 (sub 0)
Build: 2017-02-27 12:24:16 Darwin Release
argv[0] = /Applications/blender.app/Contents/MacOS/blender
argv[1] = --debug
argv[2] = --factory-startup
read file 
  Version 272 sub 2 date unknown hash unknown

ordered
 OBCube
 OBLamp
 OBCamera
found bundled python: /Applications/blender.app/Contents/MacOS/../Resources/2.78/python
blender(6034,0x7fffd539a3c0) malloc: *** error for object 0x112a9fef0: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6
Arto Kitula (akitula) raised the priority of this task from Incomplete to Needs Triage.Jun 18 2017, 11:22 PM

Just to make sure, which macOS Sierra version do you have? I can't reproduce here.

Just to make sure, which macOS Sierra version do you have? I can't reproduce here.

I have 10.12.5. It was running perfectly fine a month ago on 10.12.4.

Ok, I just have now and it comes up with the same Terminal output as before, only with different version numbers obviously.

UPDATE: I just got it working. I updated my CUDA drivers and it loaded without a hitch.

Arto Kitula (akitula) closed this task as Resolved.Jun 22 2017, 1:06 PM

Ah. Having CUDA on non-nvidia platform is quite uncommon :)
But good to know, as there might be people using thunderbolt-pci chassis.

Ah. Having CUDA on non-nvidia platform is quite uncommon :)
But good to know, as there might be people using thunderbolt-pci chassis.

My iMac actually has a NVIDIA GeForce GT 755M 1024 MB :)

I have same issue, the 2.78C and 2.79 keep hang on when start up everytime, Imac with latest iOS, the situation starts when I upgrade blender to 2.78(on 2017.06.10) and open a blender file (download from bt, its a file create on 2015)
I try to use 2.77 and work 3 days until 2017.07.12 afternoon, when I click the world icon it crash...and keep crashing that way...
My client will be mad soon..

@Jeff (bolt2009), did you try the solution suggested here, upgrading the CUDA driver?

When try to open 2.78 in terminal with sudo, it returns following text:
blender(1052, 0x7fffe18f23c0) malloc: * error for object 0x10e261fc0: pointer being freed was not allocated
set a breakpoint in malloc_error_break to debug
[1] 1051 abort

if run command line without sudo, it will be only different with:
[1] 952 abort

if I use 2.77 to continue my modeling, click world icon to crash keep happening everytime, but if I start a new file and everything just fine...but I've been working with that model for 3 month....My deadline are just in 2 weeks..

the Base Installer fix my problem, thank you very much