Page MenuHome

VSE Proxy smaller than 100% produces wrong results when using input Crop or Offset for movie strip
Closed, ResolvedPublicBUG

Description

I've noticed that when I use Crop or Offset in my input strips to select parts of the input image, these values will be misinterpreted if if I use Proxy differetn than 100% in the preview window.

This works as expected for image strips, but breaks when using movie strips instead.

Looks like the Crop and Offset is applied without compensating for the altered proxy footage dimensions. They should be compensated for the proxy size.

My use case:

I capture a single 2*1920 x 1080 resolution footage to the split it into two FullHD moving images. It's hard to edit this without using proxy and I can't use proxy because it breaks my image splitting using Crop / Offset so I'm doing my editing with 2 seconds per frame performance for now.

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from 90 to 30.Jun 21 2017, 12:44 PM

@Tobiasz Karoń (unfa) Did you actually generated proxies? As far as I can tell, wrong handling of Crop etc. values is only true when you select a Proxy preview setting and you have not generated matching proxy data - which is kind of useless actually…

Yes, I managed to generate proxies, and when I used them, Cropping was wrong so I wasn't able to benefit from them.

I'm going to try again in a recent 2.78 build, and also check in a 2.8 build to make sure.

I've checked this in recent nightly build of 2.80 and the problem persist there.

Bastien Montagne (mont29) raised the priority of this task from 30 to Normal.Jul 4 2017, 5:03 PM

The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

I've tested with a recent 2.78 nighlty build. Buit on Sat Jul 15 04:29:23 2017, name: blender-2.78-8009564503-linux-glibc219-x86_64

The issues seems to be gone, but when I tried it fro the second time, I could get the Proxy to be used, so I still had this problem. The Proxy and TC files have been deleted after generating Proxy. I think I'll file another issue.

Here's a video I captured when testing this:
https://youtu.be/So3iZfdJPrk

I guess this issue can be closed. It's a different problem now.

I found the issue.I will post the patch after I update my code to the latest master

Richard Antalik (ISS) changed the subtype of this task from "Report" to "Bug".Jan 17 2020, 12:46 AM

@Eitan (EitanSomething) when removing project Tracker Curfew a subtype has to be defined. https://code.blender.org/2019/12/tracker-curfew/

Not sure if this is reserved to maintainers only though. But if you are working on task I guess you should be able to do this.

Didn’t realize I had enough permissions even when I claim the task.

Richard Antalik (ISS) closed this task as Resolved.Fri, Jun 26, 4:50 PM

It looks like I accidentally fixed this with rB8bcfa0d1fb9f. Please let me know if the issue still persists.
Sorry for this taking so much time. It was a bit convoluted problem.

Sorry, just to confirm. Is it solved in Blender 2.9? For I saw the issue in 2.83.
Thanks for letting us know

I just got this bug in 2.90. Should I create a new task with the detailed steps to reproduce or put everything in here?

Please make a new report, and attach all the requested information (.blend, blender version and so on). Makes it easier to re-iterate over the fix.