Page MenuHome

Font seems to corrupt each time file is transferred?
Closed, InvalidPublic

Description

System Information
alienware alpha - lowest tier 4 gb ram.

Blender Version
UPBGE fork (but the bug is in bf blender as well**

Worked: (optional)

Short description of error
when packing images, and fonts, many times the image or font says it's packed,
but when you look at the text, it's default, or the image is blank**

Exact steps for others to reproduce the error
create a file, add text, pack font, send file to other computer who does not have the font.
I am not sure if it happens like this every time, will test if I get time.

Details

Type
Bug

Event Timeline

I am having trouble reproducing the bug, but it happens all the time during production*

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

We need precise steps to reproduce the issue, small and simple .blend and/or other files to do so if needed, etc. Otherwise, we cannot do much about it…

https://www.youtube.com/edit?o=U&video_id=1M78Dej4r8A

I will send my not small, complicated files to test,
I think you may be able to examine the data block for the font and see how it's broken,
however I have to share privately u - (the game is not yet in alpha)

Am sorry, but Blender is a free and open software, we do not accept private sharing of files in bug handling - and typically do not accept either to spend hours trying to understand what is going wrong in a production file with gazillions of datablocks etc.

Also, it’s usually quite simple to trim down buggy file (removing useless stuff and keep only what's needed to reproduce the issue), that way you both get simpler case, and have a file that does not need to be privately shared since it would not contain anything usable…

If the issue is not reproducible in a simple case, then it is often impossible to correctly handle anyway - tons of glitches can happen in the life of a production file (bad add-ons, corruption for whatever reason, …).

Fable Fox (fablefox) closed this task as Invalid.
Fable Fox (fablefox) claimed this task.

No updates for more than a week, no simple file to test. Closing for now.