Page MenuHome

Filmic default view isn't working correctly
Closed, InvalidPublic

Description

System Information
Windows 7 x 64, Titan X (display+render) + 780ti (render)

Blender Version
Broken: 2.78.5 e0bc5b5 (2.79 test build)
Worked: 2.78c with git hub Filmic color management

Short description of error
When the color management Display device is set to sRGB, the view to filmic and the look to none (basic filmic log transfer curve without look shaper), the result is a filmic log transfer curve with the base contrast look active.

2.78c behavior:
https://i.stack.imgur.com/WvSJa.jpg
2.78.5 test build:
https://i.stack.imgur.com/pefmg.jpg

Exact steps for others to reproduce the error
Open Blender, use default scene, switch to Cycles render (or not), hit F12.
In color manager change view to Filmic, look at the render when you change look from none to base contrast, there is no change at all.
It means that the default Filmic view have a base contrast, it's not just the filmic log transfer curve.

Why it is important
It's important to have a defaut filmic view without look shaper, this way, when we save an image in 16bits tiff with filmic, we are still able to change back to linear space, by importing the image and set the image color space to filmic log in the N panel.
It means you could encode decent amount of data in a 16bits image, you couldn't do this with an image saved in sRGB EOTF view.

I noticed something too, the defaut view without any information on the transformation (sRGB EOTF) doesn't mean a lot. In the not so friendly color management topic it's better to have a minimum of informations to avoid confusion.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Invalid.
Brecht Van Lommel (brecht) claimed this task.

These changes compared to the original filmic config are intentional.

  • No look indeed corresponds to the Base Contrast, one fewer setup step learn or forget. But also, in OpenColorIO design looks are meant to modify the image in a creative manner, not affect the output color space.
  • For digital intermediates, 16 bit half float EXR is superior to TIFF, so I suggest to use that. If there is a good reason to support writing files in filmic log, it should be implemented in another way.
  • We can't rename "Default" or "sRGB" to "sRGB EOTF" in 2.79 for backwards/forwards compatibility reasons. Further, in the filmic config it is used to name a color space, while it actually is a transformation between color spaces.

I'll not tell you how to make Blender, I haven't got the knowlege for that.
If it's intentional it's not a bug, but it doesn't change the fact that it's confusing and incorrect.
For me it's not a big deal, I can go 3rd before 2nd if I know it's this way, in this case even making without 2nd.
Being good in the colormanagement topic can profit Blender to be looked like a great tool in the CG industrie.

But also, in OpenColorIO design looks are meant to modify the image in a creative manner, not affect the output color space.

Sorry to bother again but a color space is defined by 3 things, the 3 primaries color, the white point, and the transfer curve.
So if the transfer curve is modified in fact, it is an other color space.

EXR is better, I can't tell if people making animation would profite of having a reasonable weight image that can be reconvert back to linear space.

For the last point, perhaps it can be one or two words in the tool tip, such a hard topic because of years of misunderstanding.

Thanks for your time and for making Blender better day after day.

If it's intentional it's not a bug, but it doesn't change the fact that it's confusing and incorrect.
For me it's not a big deal, I can go 3rd before 2nd if I know it's this way, in this case even making without 2nd.
Being good in the colormanagement topic can profit Blender to be looked like a great tool in the CG industrie.

Right, but these changes mostly keep the configuration more in line with CG industry standards in my opinion. I'm not aware of anything incorrect in the naming.

Sorry to bother again but a color space is defined by 3 things, the 3 primaries color, the white point, and the transfer curve.
So if the transfer curve is modified in fact, it is an other color space.

We can manipulate renders in the compositor with brightness/contrast, RGB curves or other nodes, but we don't consider the output to be in a different color space because of that. The same goes for looks, the resulting render is still displayed on a monitor that expects the same color space, or written to a file as having the same color space.

EXR is better, I can't tell if people making animation would profite of having a reasonable weight image that can be reconvert back to linear space.

Half float EXRs with DWAA compression are usually 2-3x smaller than 16 bit TIFF in my experience, if file size is a concern.

No look indeed corresponds to the Base Contrast, one fewer setup step learn or forget. But also, in OpenColorIO design looks are meant to modify the image in a creative manner, not affect the output color space.

Sorry, this isn't not what OCIO's design is based on, as discussed with the folks that both created it and the folks that are currently maintaining it.

So please don't repeat incorrect information here. This choice is entirely Blender. Valid, but not adhering to some incorrect interpretation of the OpenColorIO design. Using the creative looks is precisely appropriate given Filmic's design.

Regarding OP, the proper file format for output / display referred encodes is DPX, but DPX in Blender has been broken forever, so there are no real options to encoding 10, 12, etc. bit depth files in Blender. Half float EXRs, as terrific as they are, are sub-optimal in a number of display referred pipelines.

Can you point me to the docs or emails explaining that looks are indeed intended to affect the output color space?

Unless your point is that the None and Base Contrast in the original config result in an image in the same color space, which I see differently, but I can see it as a valid interpretation. In this particular bug report though it seems the None look is used as a compression scheme for saving digital intermediates as a 16 bit TIFF using log encoding.

If that is what the user wants to do, then I think the better solution to that would be to have a color space setting in the file Output panel where you can select Filmic Log, instead of coupling it to the display settings.