Page MenuHome

SurfacePro 4 + win10: Blank area at top. Mouse click off by blank area size.
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: 2.79 2017-06-09
Worked: 2.78c

Blank (not drawn) area above top menu bar. Using a surface pro 4, I ran at 1920x1080. This produced a blank area above the top menu bar (between the title bar and the info menu bar). This size varies based on resolution, and whether running remote desktop.

The mouse click appears to be off by the height of the blank area. ie - you have to click where the graphics *should be* and not where they actually are drawn.

Exact steps for others to reproduce the error
To reproduce the error, run at 1920x1080 on a Surface Pro 4 (windows 10). Or run a remote desktop session to a windows machine, and choose 1920x1080 as the resolution.

Event Timeline

The Surface Pro 4 has an Intel GPU, so it looks like another case of the Intel driver bug.

Not the same as T51521. T51521 says it is broken in 2.78c.
This is not the case for this instance. 2.78c (and earlier versions) work fine.

Since you mention 1920x1080 specifically, does it work correctly at the default Surface Pro 4 resolution?

Can any Windows developer reproduce this issue?

@Wouter (Waterflames), this may be related to the DPI changes.

No, it doesn't work at either resolution - but the amount of empty banding is off by a different amount.

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jul 3 2017, 5:53 PM

Please:

  • Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker).
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Try to tweak OGL settings in UserPreferences, System tab.
  • Try to tweak your GPU driver settings (e.g. try different values between 'performance' and 'quality' if you have such slider, etc.).
  • Try to place this dll next to your blender.exe (software OGL, will be slow, but will show whether this is a driver issue or not).
Bastien Montagne (mont29) renamed this task from Blank area at top. Mouse click off by blank area size. to SurfacePro 4 + win10: Blank area at top. Mouse click off by blank area size..Jul 3 2017, 5:53 PM

Thank you - I have done the following:

Updated to intels latest graphics drivers. this caused Blender 2.79 to break in a different manner (similar to T51521 ) -- ie, the top part of the info bar was covered by the title bar, and now the mouse was off in the opposite direction. It also caused 2.78c to break in the same way.

I rolled those back to the Microsoft drivers, and 2.78c worked correctly again in all cases.

Tweaking the OGL settings in User Preferences, System had no visible effect.

I then started with the --factory-startup command line option. The screen was off again in 2.79 (though it was off like the new driver was - cutting off the top of the info bar).

Putting the software OpenGL driver in place makes 2.79 look exactly like 2.78c (ie - everything is correctly drawn and it scales correctly).

So, I can only surmise that there is some sort of driver issue, however, it didn't affect 2.78c but does affect 2.79. Hopefully there will be a way to use the old method as well.

Bastien Montagne (mont29) closed this task as Archived.Jul 3 2017, 10:25 PM
Bastien Montagne (mont29) claimed this task.

Thanks for all the thorough testing, but am afraid this demonstrate once again that issue is with Intel drivers… Not much we can do here, unfortunately, besides waiting and hoping for issue to be fixed in a future driver revision. Thanks for the report anyway.

All I can say is "bummer", as it worked in 2.78c. :(

This is slowly wittling away at the machines I can use Blender on. Can't use it on my Imac anymore because, though 2.6 worked fine, 2.78c renders splotches on the model when you use a normal map. Now won't be able to use 2.79 on my surface.

I wish you could add an option to let it scale the old way, for those of us with hardware that aint going to see no driver updates.

but thanks for looking into it.

Brecht Van Lommel (brecht) reopened this task as Open.EditedJul 3 2017, 11:45 PM
Brecht Van Lommel (brecht) claimed this task.

I would like to at least investigate this a little since it is a regression due to changes in Blender. I don't think it's obviously true that there is a driver bug here, it may be that the Intel driver just uses the Windows API in a different way that we don't handle correctly, or at least can work around.

I can confirm an issue like this with an Intel HD 4600 on Windows 10 version 1607, when setting "Change the size of text, app, and other items" in the Display settings to something else than 100%. Using an NVidia GTX 1080 on the same computer shows no problem.

This appears to be caused by the new call to EnableNonClientDpiScaling, which makes the title bar scale properly along with the application. So far I couldn't find a good workaround besides just not calling that function for Intel graphics. So far I couldn't find any API function (like GetClientRect) returning different values for Intel and NVidia. It just seems to draw the contents of the Window with some offset.

Is it worth adding a setting to optionally bypass the call to EnableNoClientDpiScaling? Current intel chipsets can run Blender at very good speeds, a lot of notebook and tablet vendors are choosing to not even include discrete chipsets anymore. Even the iris 540 in the surface pro 4 is a credible solution for Unity and Blender.

If we can't find a better solution to this, I think we should automatically not call this function for Intel cards. It's only a cosmetic thing for title bars anyway.

I tried using SetThreadDpiAwarenessContext(DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE_V2) that is available in Windows 10 version 1703, but it has the same issue as EnableNonClientDpiScaling.

Disabling this title bar scaling just for Intel seems difficult, I can only find a way to detect an Intel GPU after the window has already been created. So I'm thinking of just disabling it everywhere and accepting the too small/large title bars until Intel fixes what I presume is a driver bug. Better to have functional software with a small cosmetic issue than not working at all. Unless someone has another idea to try.

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Confirmed, Medium.Jul 8 2017, 10:23 PM

I think disabling it is fine. Windows is already scaling the title bar correctly in 2.78c when you change the DPI setting.