Imported FBX Animations contains Unnecessary Keyframes
Closed, InvalidPublic

Description

System Information
Windows 10 64 bit, NVIDIA GeForce 840M

Blender Version
2.78

Short description of error
Whenever I import an animated mesh from Blender, be it using the built-in Unity FBX Importer (importing a .blend file), or the built-in Blender FBX Exporter (importing a .fbx file), the resultant AnimationClips have keyframes defined for all bones, even those that are not being animated. These bones have keyframes associated with their localPosition/localRotation/localScale and are flat linear curves -- they do nothing but hold the bone stationary. Holding bones stationary sometimes breaks animation.

I think there are two settings under Export FBX panel - Key All Bones and Force Start/End Keying but they are not working properly.

Exact steps for others to reproduce the error

  1. Setup your mesh and armature such that you have an armature named A and it has two bones a and b.
  2. Create an action named Animate_a and only animate bone a in this action.
  3. Now create an action named Idle and record only 1 key for all bones in this action(No transition).
  4. Now export FBX with default settings(FBX 7.4 Binary).
  5. Open FBX file in Unity. You will notice that the animation Animate_a contains key for all the bones and armature(A,a and b)
  1. Now repeat step 1 to 3.
  2. Before exporting FBX, Uncheck option Force Start/End Keying under Export FBX Panel and export.
  3. Open FBX file in Unity. You will notice that the animation Idle is nowhere to found.

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as "Incomplete" priority.Jul 10 2017, 8:24 PM

Don’t know what you expect here… Afaics the options are working as intended from your description…

Bastien Montagne (mont29) closed this task as "Invalid".Jul 17 2017, 1:00 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply. Due to the policy of the tracker archiving for until required info/data are provided.

Sumit Chaudhary (code.sumit) raised the priority of this task from "Incomplete" to "High".Aug 5 2017, 6:08 AM
Sumit Chaudhary (code.sumit) reopened this task as "Open".

For a perticular animation(LeftDoorOpen) I don't want to key all bones while also keeping the 'Idle' animation in exported fbx file. Please tell me a way to do it.

Option 'Key All Bones' does nothing and option 'Force Start/End Keying' drop the animations with no transformation (ex: Idle).

This is a well known problem in blender fbx export for a very long time. Check this post-

http://answers.unity3d.com/questions/710376/import-blender-animation-without-unnecessary-keyfr.html

Please solve this problem. Everyone I contacted have acknowledged this problem but nobody has a solution. The only workaround I discovered -

  1. Move or rotate bones to a negligible value(0.0001 ) in 'Idle' action.
  2. While exporting, uncheck 'Force Start/End Keying'.

But this is not correct way so please give me a solution.

Thanks in advance.

Bastien Montagne (mont29) lowered the priority of this task from "High" to "Incomplete".Aug 31 2017, 4:37 PM

Setting priority yourself is not a good idea, especially not to high. Also, this report does not sounds like a bug report at all, more like a feature request. And finally, we are lacking simple demo files here, as requested by submission template.

Bastien Montagne (mont29) closed this task as "Invalid".Sep 11 2017, 1:58 PM

More than a week without reply. Due to the policy of the tracker archiving for until required info/data are provided.