Empty VSE preview for scene strips with OpenGL preview + Rendered settings
Closed, ResolvedPublic

Description

System Information
ubuntu 14.04
AMD Athlon(tm) II X4 630 Processor × 4
Gallium 0.4 on AMD RS780 (DRM 2.43.0 / 4.4.0-83-generic, LLVM 3.8.0)
64-bit
1.7gb ram

Blender Version
Broken: 2.78c e92f2352830
Worked: none

Short description of error

Exact steps for others to reproduce the error
create an empty scene and put ate compositor

create in the blender file multiple scenes, each scene with diferente group characters and group props linked after the creation of the composite scene.

if you put the scenes on the sequencer at the first scene (named composite for example) you will see nothing on sequencer view, should be able to see even if you create first, but it only works if you create the composite scene later. so you can not link anything new without deleting and creating a new composite scene.

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as Incomplete priority.Jul 19 2017, 10:54 AM

Please follow our submission template and guidelines and make a complete, valid bug report, with required info, precise description of the issue, precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

Sorry, but what is missing?

Please add a blend file that shows the error.

did it! I just don know if the attach worked!

Hi,

If the attach work there will be a button that let people download the file. An example of a bug report with attached .blender file is here T52149 . Note the err3d.blend


here the attached files

same problem with the 2.79 test build Date: 2017-08-01 17:31 Hash:5e9132b3b7d.

At the sequencer view you should see a monkey linked by scenes. Char1.blend is the source file where the monkey is a group and Link Error.blend is a general link file.

Bastien Montagne (mont29) raised the priority of this task from Incomplete to Normal.Aug 11 2017, 2:50 PM

Thanks for the files…

Only weird thing here (and afaict, totally unrelated to linking) is that, in VSE preview settings, the combination of 'Rendered' preview with 'OpenGL Preview' option enabled gives empty preview.

@Sergey Sharybin (sergey), @Campbell Barton (campbellbarton), do you guys know what should happen in that case?

Bastien Montagne (mont29) renamed this task from Link Problem! to Empty VSE preview for scene strips with OpenGL preview + Rendered settings.Aug 11 2017, 3:01 PM

@Bastien Montagne (mont29), i'm not sure what is motivation in current code, but think OpenGL Preview is a historical redundancy from times when it was the only option to switch between final render and some shaded mode. Think now we need to remove that option and make internally things behave like:

  • If shading mode is Rendered assume OpenGL Preview option as disabled
  • For other shading mode assume OpenGL Preview option enabled

In the middle of something else now so might sound confusing, but hope you got the idea :)

Bastien Montagne (mont29) closed this task as Resolved.Aug 11 2017, 6:09 PM

Guys, at the blender 2.79 rc2 the problema steel remains. The only change was that the sequencer screen got black. Same files sended before, but I alredy tried to remake the files at the rc2 and the problem is the same.

@Ivam Pretti (ivampretti) since there is no light at all in your scenes added as strips in the VSE… no wonder they render pitch black ;)