Blender 2.78 crashing on startup
Closed, InvalidPublic

Description

System Information

OS: Windows 10 64-bit, latest version. GPU: NVIDIA Geforce GTX 970M, latest driver.
Blender Version
Broken: (2.78)
Worked: none (fresh install, new user)

Short description of error

When trying to run blender, a command prompt box opens up saying "AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead" for about 2-3 seconds, followed by "Error: EXCEPTION_ACCESS_VIOLATION". The command window then closes abruptly.

No error log is generated in the Temp folder as reported by other users with the same issue. However, every time the crash occurs it generates an empty folder named "blender_a12345", with a random five-digit number. These folders have no error logs or files in them at all.

I have tried running it as an administrator, no change whatsoever.

I have also tried reinstalling several times using both the .zip and the installer, and have installed both 64-bit and 32-bit versions, to no avail.

I have tried installing an older version of Blender (2.70a). After doing so, the command prompt comes up with no text, then blender opens up as a large white window, then instantly crashes with a windows-default "Blender.exe has stopped working" message. Still no error log generated.

Exact steps for others to reproduce the error
I do not know how to replicate this issue. I simply installed blender 2.78 directly from the official website and am trying to run the program, which instantly crashes every time.

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as Incomplete priority.Jul 18 2017, 9:32 AM

Did you try the latest build from our buildbot? This sounds like driver issue, so may not fix anything - but hopefully should give nicer error message, if it’s a GPU issue…

To get driver issue out of the way, you can try software rendering.

Try replacing the opengl driver with a software version from

http://download.blender.org/ftp/sergey/softwaregl/win64/opengl32.dll

just copy the dll into your blender folder (and remove it when you are done testing, performance will be very bad otherwise) and see if that improves things.

Fable Fox (fablefox) closed this task as Invalid.Jul 27 2017, 4:31 AM
Fable Fox (fablefox) claimed this task.

More than a week passed without a reply.

Due to the tracker policy, archiving until the required additional information / data is provided.

I got the same problem, too. need resolve

I got the same problem on 1 pc. copying opengl32.dll works, but no clue what to do next. (version 2.79)

@Edwin van het Bolscher (3ddy) If copying the opengl32.dll works means that the gpu driver is the problem. Try updating them to the newest version (or find a version that works based on the hardware you have)
The other possibility is old hardware that doesn't support OpenGL 2.1.

It's not only Blender, it's also Adobe Photoshop. After installing the oldest driver and the newest driver available online, it did not work.

I managed to disable my oldest videocard (a Nvidia Geforce GTX 560) and after that it worked. My GTX 760 is still enabled.