Page MenuHome

Local pass index gets ignored for linked objects
Closed, InvalidPublic

Description

System Information
Wint8.1x64, 3x gtx580

Blender Version
2.79t1

Short description of error
Rendering (Cycles) uses pass index from a linked file instead of the local attribute (when linking a character group etc.).

One can argue it's a feature not a bug as different linked object parts can have different IDs, but that also defeats the purpose of linking, as one has to link different object copies for different scenes.

Exact steps for others to reproduce the error

  • Copy both attached files to same folder and open "link-id.blend"
  • OR open "link-id.blend" and link a group from "sample.blend"
  • Change Pass Index of the linked object to 3 and render. The nodes are set up to show objects with ID==3, yet the linked object does not show in the render.


Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Normal priority.

Thanks for the report, but this has absolutely nothing to do with linking - thing here is that pass ID of group instantiations is not used for group’s objects

I’d think there is no bug here, @Sergey Sharybin (sergey) should know better though. :)

Brecht Van Lommel (brecht) closed this task as Invalid.

This is indeed not a bug, the pass ID is not inherited by objects in the group. Overriding the ID is not always the desired behavior, it depends. The new collections / overrides planned in 2.8 are intended to let you control this kind of thing.