Page MenuHome

Motion blur sometimes fails to finish the frame properly (particle simulation)
Closed, ArchivedPublic

Description

System Information
Windows 10. GTX 960 TI

Blender Version
Broken: 2.78c
Worked: (optional)

Short description of error
I've now rendered 3 different animations with those same stars and 2 of them had frames in random places where the motion blur creates bad errors. Frames with and without the problem:
https://www.dropbox.com/s/mqa192qepcntakz/0063.png?dl=0 https://www.dropbox.com/s/bg372z18pd2rppf/0064.png?dl=0

Exact steps for others to reproduce the error
The only way I know to do this is to create a particle simulation that emits mesh objects. If you have emission shader on the particles, it makes it easier to spot the frames where the problem is. Now activate motion blur and render the animation. Sometimes you have this error because of unknown reasons. In my simulation, it was the frame 64, but cannot anymore be able to have the problem in the same frame.

https://www.dropbox.com/s/8dl0npl0s7a32r8/stars.blend?dl=0

Details

Type
Bug

Event Timeline

macOS 10.12.5, MacBook Air, NVIDIA GeForce 320M 256 MB
Daily build 2017-07-18 02:14, Hash: 66383ea206 and 2.78c official

I can consistently reproduce the reported issue for frame 63 on the configurations above, though I can prevent it reoccurring by baking the particle system for the emitter in properties -> particles -> cache.

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Currently rendering with motion blur requires you to bake all physics simulations in advance. We have a to do item about better communicating when this, but for now it's not considered a bug.