Page MenuHome

Denoising feature. Bug on GPU render (Mac OsX 10.11.6)
Closed, ArchivedPublic

Description

System Information
Osx 10.11.6 (MacBookPro11,5 Intel Core i7)
AMD Radeon R9-M370X

Blender Version
2.78-db8bc1d9829-OSX-10.6 (jul 21)

Short description of error
Denoising feature is not working on GPU rendering. It works on CPU rendering. Using Cycles.

Scene test

CPU render

GPU render

Exact steps for others to reproduce the error
I just created a mokey with a diffuse shader and sun lamp. Denoising activated using default settings and rendered on CPU and GPU. Tested several times with similar corrupt image result on GPU.

Details

Type
Bug

Event Timeline

david serrano (dserama) renamed this task from Denoising bug on GPU render (Mac OsX 10.11.6) to Denoising feature. Bug on GPU render (Mac OsX 10.11.6).

I tried to repro this with Intel + macOS (with a simplified megakernel since the full one doesn't work), but denoising seemed to work ok. @Mai Lavelle (maiself), do you have a way to test this perhaps? Not sure who maintains macOS OpenCL now.

I can't reproduce this with the hardware I have available (no macOS here). Maybe @Lukas Stockner (lukasstockner97) can take a look?

Sergey Sharybin (sergey) claimed this task.
Sergey Sharybin (sergey) triaged this task as Confirmed, Medium priority.

I can reproduce the issue on so called trashcan here in the studio.

Would need to have a closer look, but flying to conference tomorrow. So if someone fees like looking into the issue -- by the all means please go ahead.

I have the 'same' issue, except that the rendered tiles on GPU are completely black. No artifacts.
OSX 10.12.6
iMac 5k, 4Ghz Intel i7
AMD Radeon R9 M395X 4096Mb

same as Roel "rendered tiles on GPU are completely black. No artifacts." (entire render is black)
using 10.13.1
radeon pro 580
if I go into the denoiser settings and turn off direct diffuse the denoised tiles aren't black

I have this black tile issue with denonising on GPU also. Im running an iMac Pro with the Radeon Pro Vega 64 16 GB graphics card, for me I have to turn off all the direct denoising to get an image looking like the expected render

using blender version: 2.79 5bd8ac9 and OSX version: 10.13.2

On a side note is there anything I can do for testing as it would be good to get the iMac Pro especially the GPU side of it working well on blender (currently I don't think its taking full advantage of the GPU?)

AMD GPU rendering on Mac is indeed quite poor currently, partially due to bugs in the OpenCL driver, partially due to none of the Cycles developers having this hardware or enough time to optimize for it. There's not much users can do in testing, it mainly requires a developer to spend significant time.

This bug excists for more than 8 months... what about a solution?

This comment was removed by david serrano (dserama).

Having the same issue as everyone else- the denoising filter turns all tiles black. Deactivated it and everything rendered fine.

Blender 2.79
OSX 10.13.4
iMac Pro
Radeon Pro Vega 64 16368 MB

The black tiles issue when rendering with AMD GPU + Denoiser on Mac is still there in 2.8, and it's fully reproducable. Is there a chance of this being fixed in the near future? That'd be great.

Thanks.

Yeah it would totally be great if this could be fixed! I tried it with 2.8 and 2.79b without success,.. With 2.8 I get the random black tiles. I just tried it again with 2.79b but that made my Mac reboot itself:( Tried it again just to be sure but the second time my whole screen went yellow and I had to unplug my eGPU.
Using a MacBook Pro 2018 i9 32GB ram with AMD Vega56 eGPU running MacOS Mojave.
Really hoping this can get fixed soon. In the meantime, does anyone know a way to still use the denoise function?

Well, guess its finally time to get this tackled. Been delaying this for quite some time, since this is one of the things which doesn't really have a happy end :(

The actual problem here is caused by a bug in an OpenCL compiler. While it's sometimes possible to work around broken compiler, so far i did not find a working solution for this issue. But even this particular case is solved, with every new feature being added we've got high probability of compiler breaking again. This is not sustainable way of maintaining the project.

The only acceptable solution would be to get OpenCL driver fixed, but Apple announced deprecation of OpenCL and will no longer develop it further.

In order to keep available features in Blender stable and predictable, the decision was made to disable OpenCL support on macOS,

The change, release notes and mailing list announcement will come shortly.

Sergey Sharybin (sergey) closed this task as Archived.Dec 7 2018, 3:18 PM

Commit: rBbb0d812d98f.
Link to the mailing list: https://lists.blender.org/pipermail/bf-committers/2018-December/049695.html
Link to the release notes: https://wiki.blender.org/wiki/Reference/Release_Notes/2.80/Cycles#GPU_rendering

Thanks for the report, but we really can not solve issues in OpenCL compilers.

Apple will not longer develop OpenCL... So what about Metal? This is the new one. It's much much faster on Mac and is the new language! Will Blender ever support Metal? This'd be a great idea: much faster render times on Mac, denoising and baking would work as well. Can we expect something like this for 2.81??? It would bring up Blender for a new level on Mac!

@Hans-Simon Sagave (wizardx) I read that there are plans for a Metal wrapper for Vulkan in the future. I guess a pure Metal version of Blender would require maintaining a separate macOS branch. But if you already want a taste of Metal-assisted rendering, you can try Radeon ProRender. It's quite well-integrated in Blender and is also free.