Playback twice as slow when armature selected.
Closed, ArchivedPublic

Description

System Information
Window10,
i7-4770
12 gb ram.
Asus Geforce GTX 1060 6gb

Blender Version
Broken: 2.78.5 hash 66383ea
Worked: (optional)

Short description of error
When i hit play, the playback is at around 10fps, if I make an other object that's not that armature active, it will go up to 20fps, (the gif shows it at around 17 i guess recording the screen makes it slower)

Exact steps for others to reproduce the error
As you can see is a simple scene with the agent dowloaded from the cloud linked, using the low res version and animating it.
I can provide the files upon request if that will aid the process of debugging.

Details

Type
Bug
Sergey Sharybin (sergey) closed this task as Archived.Jul 28 2017, 3:13 PM
Sergey Sharybin (sergey) claimed this task.

Thanks for the report, but it's not really a bug. All the selected Objects in Blender are drawn twice --first pass for outline, second time for the actual content. This is something nice for optimization in 2.8 branch where the drawing method changed completely.

Hi Looch,

Great to see you in the tracker! Please never hesitate to report issues, but keep in mind that the tracker is first meant to help the coders.
You can already do a lot of investigations yourself. Next time, just attach a small file that shows the issue. It's only a real bug if someone can redo it on their own system (easily).

Yeah Ton, thanks for the advice, usually when I can I do.
the reason I didn't put files, it's because in this case it was 300 mb worth of files and I didn't really know if it was necessary unless someone asked me, that's why I left that line in the end, if in need I would definitelly upload.
the other reason is that collecting files that are linked isn't very streamlined, but that's for an other time =)
Will keep reporting as i find things!.
Anyways, don't want to bother you guys too much, keep rocking it!