Page MenuHome

Rigify "Rigify Type" lags bone properties panel.
Closed, ResolvedPublic

Description

System Information
Win10 Asus GTG1060

Blender Version
Broken: 2.78.5 hash 66383ea
Worked: 2.78

Short description of error
when the rigify type panel from the bone properties panel is open, it makes that whole properties panel very slow, if you close it, it stops lagging instantly.

Exact steps for others to reproduce the error
open blender,
go to addons and activate rigify addon.
create an armature
select a bone in pose mode
go to the bone properties panel
open the "rigify type" panel at the bottom
see how that whole panel is very laggy.

Details

Type
Bug

Event Timeline

I can't conform that.
It could be related to some script running in background, or just a graphic driver issue.
@Lucio Rossi (luciorossi) @Brendon Murphy (meta-androcto) Can anyone else please confirm this is happening?

hi, unable to confirm here also

First time that I notice it, but there is a slight lag in that specific panel update... the poll function probably needs a recode, I'm checking

@Luciano Muñoz Sessarego (looch)
Could you please try the attached patch?
The problem was probably the Panel draw method calling a function that's importing modules at runtime

Lucio Rossi (luciorossi) triaged this task as Confirmed, Medium priority.Jul 27 2017, 4:14 PM

@Luciano Muñoz Sessarego (looch)

Hi try to substitute the files in the attached .rar:

  • make a backup copy of the files ui.py and rig_lists.py you find in rigify main folder
  • unzip the content in the same folder and overwrite

I hope it can solve it
Lucio

Lucio Rossi (luciorossi) closed this task as Resolved.Jul 28 2017, 12:08 PM

Sorry i never responded i didnt seem to receive any notifications i'm glad the issue is solved