curves with solidify bug if subdivided (3 verts on a line)
Closed, ArchivedPublic

Description

System Information
Win 7 x64

Blender Version
Broken: 2.79 testbuild 2

Short description of error
If a curve has 3 vert on a line, the solidify modifier will create buggy geometry

Exact steps for others to reproduce the error
Open attached file, it has triangles in the oposite direction.


Delete the subdivided vert on the buggy face, it now works.

Details

Type
To Do
Sergey Sharybin (sergey) triaged this task as Confirmed priority.Jul 28 2017, 11:06 AM
Sergey Sharybin (sergey) claimed this task.

Might be a precision error or so. Not sure why it is specific to curves only. Need some extra investigation.

@Bastien Montagne (mont29), if you feel like having a look here please be welcome :)

Managed to reproduce the same on mesh:

Talked to @Campbell Barton (campbellbarton) in IRC, possible workaround would be to run beautify after scanfill for curves. For meshes we can't do much, just avoid creating degenerated cases. But for curves we'll try to work something around in the code.

Campbell Barton (campbellbarton) closed this task as Archived.EditedMar 21 2018, 12:04 PM

I'd consider this a high priority TODO, since this is caused by multiple features interacting poorly - but not a mistake in a single feature.

Added to TODO:

https://wiki.blender.org/index.php/Dev:Source/Development/Todo/Tools#Solidify_Modifier