Page MenuHome

conversion of text objects to mesh generate improper mesh for letter T (even with default text font)
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Windows 7sp1x64
renderer: 'Intel(R) Q45/Q43 Express Chipset'
vendor: 'Intel'
version: '2.1.0 - Build 8.15.10.2869'

Blender Version
2.79 rc1, ie: 2.78 (sub 5), branch: master, commit date: 2017-07-13 10:50, hash: 248bba81e7a
and also blender-2.78.0-git.9e929c9-windows64
...and back to 2.49b !

Short description of error
The conversion of the "T" or "t" (upper case or lowercase) letter to mesh is screwed, and generates a wrong face setup that can then screw later editing of the mesh.
This happens also with default font (bfont). All letters have terrible topology, but no other letter seems to be converted as wrong as T or t

I found about this following a user issue on BSE:
https://blender.stackexchange.com/questions/86292/solidified-extruded-text-mesh-errors

...of course he has trouble both:

  • extruding and then converting
  • converting andf then using solidify modifier

Exact steps for others to reproduce the error

Insert a default text object ("Text"),
then convert to mesh (ALT-C)
in edit mode, set face select mode
look at the faces of the T letter O_o

To better see it:

Insert a default text object (just an uppercase "T"),

then convert to mesh (ALT-C)
in edit mode, set face select mode
set "solid" shading mode and "limit selection to visible"

then use CTRL-B to select all the visible faces

then, invert the selection (CTRL-I)

...there are "hidden faces" there...

Details

Type
Bug

Event Timeline

the triangulation indeed produces 0 area degenerated faces, which can't be cleaned with limited dissolve.

The 3D print toolbox can't make the meshes manifold and find a lot of errors, mostly due to zero area faces. It happens on e too, but e can be cleaned with limited dissolve.

Like matali23 said limited dissolve wont work with 0 area faces, but the degenerate dissolve will. The solution for me (maybe only in my case) was to apply degenerate dissolve untill i had no edge or face removed then triangulate again the mesh.
Unfortunately I don't now if degenerate dissolve can have any unwanted side effect.

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but text “meshification” leading to terrible topology is very old know issue, nothing new here, that is not considered as a bug currently.