Shading difference between applied and unapplied subsurf modifier
Closed, ArchivedPublic

Description

System Information
Win7 64bit

Blender Version
Broken: 2.78c

Short description of error
Left is live subsurf+crease, right - applied subsurf+crease

Exact steps for others to reproduce the error
Apply modifier on the left mesh, see no difference, then go into edit mode and back to object -> shading becomes different

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as "Confirmed" priority.Jul 31 2017, 4:22 PM

Not sure… looks like the 'sharp' status of corner vertices somehow survive the subsurf modifier (while sharp edges being totally lost)… maybe @Sergey Sharybin (sergey) will want to have a look?

Sergey Sharybin (sergey) closed this task as "Archived".Wed, Sep 13, 1:38 PM
Sergey Sharybin (sergey) claimed this task.

Existing subsurf code isn't really good for sharp geometry (both vertices and edges). OpenSubdiv handles those better, but current implementation lacks proper smooth normals due to OpenGL restrictions. Those restrictions are gone in 2.8 branch, so it's possible to have high quality subsurf in there, just need some time to implement missing bits.

So while it's annoying issue, tryign to solve it for the current subsirf code is not really best time investment, especially since it's not a regression. Just get some patience, give us time to finish full integration of OpenSubdiv. That would be a proper way to solve issues.