Time Slide tool doesn't take NLA mapping into account
Closed, ResolvedPublic

Description

Windows 7 64-bit, GTX 770 OC

Blender 2.78.5 5c96312

While Tweaking Strip Actions (Tab), if the actual keyframes of the action are different from the NLA's relative location, Alt+RMB doesn't select them in the Graph Editor. They can be selected correctly in the Dopesheet.
For example, if the Action's first keyframe is set at frame 0 while the NLA track starts at frame 45, the key can't be selected this way in the Graph Editor.

edit: also Timeslide (Shift+T) doesn't work correctly in Dope Sheet during Tweak mode. It will only work if the cursor starts in the exact frame range (not the NLA's offset range)
edit2: Pose Breakdowner also doesn't work correctly in Tweak Mode. Again, it doesn't account for the offset of the active NLA Strip. Also changed title since there's probably something else.
edit3: moving keyframes in the Graph Editor starts by jumping back to the actual keyframe locations

¿? (edtion) renamed this task from Alt+Right Click Doesn't Select (offset) keys while Tweaking Strip Actions (NLA) to Multiple commands don't work correctly while Tweaking Strip Actions (NLA).Jul 31 2017, 12:39 AM
¿? (edtion) updated the task description. (Show Details)
Bastien Montagne (mont29) triaged this task as Normal priority.

@Joshua Leung (aligorith) not sure whether this is supposed to work or not in tweak mode?

Joshua Leung (aligorith) raised the priority of this task from Normal to Confirmed.Aug 1 2017, 7:02 AM

I finally got around to checking on this report again today.

  • It appears that most of the previous issues are no longer occurring now, so I assume that all of those were caused by T52327
  • Only the Time Slide tool still seems to be broken. Looking into it, it seems that it wasn't set up to work with NLA offsets yet (though it probably should)
Joshua Leung (aligorith) renamed this task from Multiple commands don't work correctly while Tweaking Strip Actions (NLA) to Time Slide tool doesn't take NLA mapping into account.Aug 23 2017, 4:15 AM
¿? (edtion) reopened this task as Open.Sep 11 2017, 2:25 PM

Wasn't sure if this was supposed to be re-opened, submitted as new, or mentioned as a note but:

Alt+RMB still doesn't work for "moved" tracks. If you move a track around, this select doesn't work in "Graph Editor", unless you Apply the scale (even if it wasn't scaled).
Everything else seems to work though :)

¿? (edtion) closed this task as Resolved.Sep 11 2017, 2:48 PM

(may be redundant but while browsing my reports from last year, Bastion told me to not re-open tasks myself, and considering I'm not even sure if it's the same thing, I re-closed it )