Page MenuHome

UV islands without margin are rotating buggy around individual origins
Closed, ArchivedPublic

Description

System Information
Win7 64bit

Blender Version
Broken: 2.78c

Short description of error

Exact steps for others to reproduce the error
Hit Unwrap, set margin to zero
In UV editor hit R90 for rotating -> some faces are doing it wrongly

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.

Confirmed, looks like some faces are not correctly split as separated items…

Apparently this is the expected behavior. There is nothing in the code indicating that edges marked as seam delimit islands. The faces that are "not correctly split", coincidentally share the same vertices (with the distance between them less than STD_UV_CONNECT_LIMIT).

Demeter Dzadik (Mets) closed this task as Archived.
Demeter Dzadik (Mets) claimed this task.

Doesn't look like a bug to me, unless seams are supposed to delimit islands. Anyone mind if I close this?