VSE/Viewport: No Audio
Closed, ArchivedPublic

Description

Windows 7 64-bit, GTX 770 OC

Broken: 2.79RC 6af7d7e
Worked: 2.78C e92f235283

Audio tracks will only play once. There appears to be a cache which after an audio segment is cached, it no longer plays.
Playback (alt+A) through an audio clip or Audio Scrub through it and it will play the first time you go over an area; afterwards no sound is played.

Changing Sound settings in Preferences>>System seems to reset this cache, allowing audio to be played once more.

Details

Type
Bug

I can't seem to have that problem with Arch Linux

Aaron Carlisle (Blendify) triaged this task as Incomplete priority.Aug 20 2017, 7:07 AM

Are there any errors in the Command Prompt? This can be found with:

Info Editor --> Window -- > Toggle Command Prompt.

No but it's "currently" working in ac28a4f

I'm not saying something was fixed or it'll stay fixed but this specific version plays audio correctly and prior versions (notably the one I mentioned) do not.

Can you try with the 2 release candidate from https://www.blender.org/download/

Is Audio supposed to play while running backwards? Because it doesn't (but it'll scrub).
Audio doesn't play if you start playing from inside the track then set the current frame to negative frames.

Bastien Montagne (mont29) closed this task as Archived.Aug 31 2017, 4:21 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply. Due to the policy of the tracker archiving for until required info/data are provided.

Was I supposed to provide that info/data?

I think you didn't reply to Aaron by telling if you did try on RC2

Also check the command line to see is there are any messages.

First reply = at Aaron and a statement that the issue is not in the specified build
Second reply = Notes on RC2 (unsure if new issues or intended)
Issue not in RC2.

Because the error occurred but no information was given as to it being fixed, it's possible the source and solution were in matters unrelated to this.
Which is why I can only say that it "works" in specific builds and to not say it is "fixed".
If no one is claiming they fixed it, it could be added again without someone knowing it's happening.